Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

68 Cookbooks RSS

  • artifact_legacy 3.2.0

    38% Updated January 6, 2017

    Provides your cookbooks with the Artifact Deploy LWRP (Updated to latest AWS-SDK compatible with ruby 1.9.3)

    cookbook 'artifact_legacy', '~> 3.2.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • windows >= 6.0
  • mecab-ruby 0.1.1

    25% Updated November 8, 2016
    Deprecated

    Installs an official ruby binding for mecab

    cookbook 'mecab-ruby', '~> 0.1.1'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
  • prun-cfg 0.2.35

    38% Updated September 4, 2016

    Helps to configure PRUN servers (PostgreSQL / Ruby on Rails/ Ubuntu / Nginx)

    cookbook 'prun-cfg', '~> 0.2.35'
    Supported Platforms
    • ubuntu >= 0.0.0
  • rubyzip 1.3.1

    25% Updated July 26, 2016
    Deprecated in favor of poise-archive

    Library cookbook which installs and configures rubyzip.

    cookbook 'rubyzip', '~> 1.3.1'
    Supported Platforms
    • centos >= 0.0.0
    • freebsd >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • arch >= 0.0.0
    • windows >= 0.0.0
    • solaris2 >= 0.0.0
  • et_fog 4.0.1

    50% Updated July 15, 2016

    Installs/Configures the Fog ruby library

    cookbook 'et_fog', '~> 4.0.1'
    Supported Platforms
    • ubuntu = 14.04
  • ruby_rbenv_download 0.1.0

    38% Updated June 10, 2016

    Provides ruby_rbenv_download to download ruby from binaries

    cookbook 'ruby_rbenv_download', '~> 0.1.0'
    Supported Platforms
  • br-ruby 0.5.2

    38% Updated May 17, 2016

    Installs Ruby versions

    cookbook 'br-ruby', '~> 0.5.2'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
  • brightbox-ruby 1.2.2

    50% Updated May 12, 2016

    Handles managing Rubies from brightbox

    cookbook 'brightbox-ruby', '~> 1.2.2'
    Supported Platforms
    • ubuntu >= 0.0.0
  • bjn_ruby 2.2.3

    38% Updated May 9, 2016

    Ruby for Blue Jeans nodes

    cookbook 'bjn_ruby', '~> 2.2.3'
    Supported Platforms
    • ubuntu >= 0.0.0
  • mw_application 0.2.2

    25% Updated April 25, 2016

    Provides application, application_ruby resources and helpers to create new application LWRPs

    cookbook 'mw_application', '~> 0.2.2'
    Supported Platforms
  • ruby 1.0.0

    75% Updated March 24, 2016
    Deprecated

    Installs Ruby and related packages

    cookbook 'ruby', '~> 1.0.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • suse >= 0.0.0
    • gentoo >= 0.0.0
    • arch >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
    • oracle >= 0.0.0
  • rubyenv 0.1.4

    38% Updated January 26, 2016

    Install one or more ruby versions with rbenv

    cookbook 'rubyenv', '~> 0.1.4'
    Supported Platforms
    • ubuntu = 14.04
    • centos = 6.6
  • ish 0.2.2

    38% Updated December 29, 2015

    utility recipes for spawning resources pi-style. 0.2.1 - static_wasya2 ok 0.2.2 - rbenv, not ruby_rbenv

    cookbook 'ish', '~> 0.2.2'
    Supported Platforms
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
  • application_just_ruby 0.0.1

    13% Updated December 11, 2015
    Deprecated in favor of application_ruby

    Deploys and configures Ruby-based applications

    cookbook 'application_just_ruby', '~> 0.0.1'
    Supported Platforms
  • cloudless-box 2.0.0

    50% Updated November 10, 2015

    Cloudless box is an opinionated solution to run one or more Ruby on Rails, Node or Meteor applications on single server with databases, backup, firewall and more.

    cookbook 'cloudless-box', '~> 2.0.0'
    Supported Platforms
    • centos >= 7.0
  • ruby-enterprise-install 0.2.8

    38% Updated November 10, 2015

    Installs/Configures ruby-enterprise

    cookbook 'ruby-enterprise-install', '~> 0.2.8'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
  • ruby_lwrp 0.1.8

    50% Updated September 29, 2015

    Installs chruby and ruby-build to build rubies from source

    cookbook 'ruby_lwrp', '~> 0.1.8'
    Supported Platforms
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
  • ruby-install 0.2.0

    50% Updated August 22, 2015

    Installs postmodern's ruby-install and optionally Ruby versions.

    cookbook 'ruby-install', '~> 0.2.0'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • mac_os_x >= 0.0.0
  • ruby_install 1.0.5

    50% Updated May 30, 2015

    Installs/Configures ruby-install

    cookbook 'ruby_install', '~> 1.0.5'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
  • gem_installation 2.1.0

    38% Updated April 28, 2015

    Installs ruby gems and their dependencies

    cookbook 'gem_installation', '~> 2.1.0'
    Supported Platforms
    • debian >= 0.0.0
    • ubuntu >= 0.0.0