Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

bjn_ruby (7) Versions 2.2.3

Ruby for Blue Jeans nodes

Berkshelf/Librarian
Policyfile
Knife
cookbook 'bjn_ruby', '~> 2.2.3'
cookbook 'bjn_ruby', '~> 2.2.3', :supermarket
knife cookbook site install bjn_ruby
knife cookbook site download bjn_ruby
README
Dependencies
Quality

bjn_ruby Version

Installs the Ruby programming language from the Brightbox repository. Also includes common ancillary packages (e.g. bundler).

Requirements

This cookbook depends on apt and magic. The following platforms are officially supported:

  • Ubuntu 12.04
  • Ubuntu 14.04

Attributes

Attributes are documented inline, so check out attributes/default.rb. You prolly don't want to touch anything except the version, though.

Recipes

This cookbook contains only a default recipe, which installs Ruby and friends.

Dependent cookbooks

magic >= 0.0.0
apt >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

2.2.3 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

2.2.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

2.2.3 failed this metric

FC064: Ensure issues_url is set in metadata: bjn_ruby/metadata.rb:1
FC065: Ensure source_url is set in metadata: bjn_ruby/metadata.rb:1
FC066: Ensure chef_version is set in metadata: bjn_ruby/metadata.rb:1
FC076: Metadata uses the deprecated "conflicts" keyword: bjn_ruby/metadata.rb:1
Run with Foodcritic Version 11.1.0 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

2.2.3 failed this metric

bjn_ruby does not have a valid open source license.
Acceptable licenses include Apache-2.0, apachev2, Apache 2.0, MIT, mit, GPL-2.0, gplv2, GNU Public License 2.0, GPL-3.0, gplv3, GNU Public License 3.0.

No Binaries Metric
            

2.2.3 passed this metric

Publish Metric
            

2.2.3 passed this metric

Supported Platforms Metric
            

2.2.3 passed this metric

Testing File Metric
            

2.2.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

2.2.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number