Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

ruby_lwrp (4) Versions 0.1.8

Installs chruby and ruby-build to build rubies from source

Berkshelf/Librarian
Policyfile
Knife
cookbook 'ruby_lwrp', '~> 0.1.8'
cookbook 'ruby_lwrp', '~> 0.1.8', :supermarket
knife cookbook site install ruby_lwrp
knife cookbook site download ruby_lwrp
README
Dependencies
Changelog
Quality

Description

Cookbook Version Code Climate Build Status

Cookbook ruby_lwrp builds various versions of ruby and installs them to /opt/rubies. It uses ruby-build to build and install ruby and chruby for switching between installed ruby versions.

Requirements

Platform:

  • Debian
  • Ubuntu

Cookbooks:

No dependencies defined

Attributes

  • node['ruby']['chruby']['install_path'] - Defaults to "/opt/chruby".
  • node['ruby']['chruby']['home_prefix'] - Defaults to "/home".
  • node['ruby']['chruby']['git_url'] - Defaults to "git://github.com/postmodern/chruby.git".
  • node['ruby']['chruby']['git_ref'] - Defaults to "master".
  • node['ruby']['chruby']['install_pkgs'] - Defaults to "%w(make git-core)".
  • node['ruby']['ruby_build']['install_path'] - Defaults to "/opt/ruby-build".
  • node['ruby']['ruby_build']['git_url'] - Defaults to "git://github.com/sstephenson/ruby-build.git".
  • node['ruby']['ruby_build']['git_ref'] - Defaults to "master".
  • node['ruby']['ruby_build']['install_pkgs'] - Defaults to "%w(build-essential bison openssl libreadline6 libreadline6-dev zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev autoconf libc6-dev ssl-cert subversion git-core libffi-dev)".
  • node['ruby']['ruby_build']['tmp_dir_path'] - Defaults to '"/tmp"'. It sets TMPDIR for ruby-build.

Recipes

  • ruby_lwrp::default - Includes ruby_build and chruby recipes.
  • ruby_lwrp::chruby - Installs the Chruby to /opt/chruby and prepares Chef to ruby_set the LWRP.
  • ruby_lwrp::ruby_build - Installs the ruby-build to /opt/ruby-build and prepares Chef to use ruby_install LWRP.

LWRP

ruby_install

Actions

  • install: Builds and installs ruby, includes chruby functions via /etc/profile.d/.

Attribute Parameters

  • definition: This attribute defines ruby version. Should be in ruby-build definition list;
  • prefix: Set install prefix for ruby-build, default is /opt/rubies;
  • build_ruby: Build ruby from sources via ruby-build. True by default. If False, try to install system ruby package.

ruby_set

Actions

  • set: Install chruby_auto helper to user's .profile and create .rubyversion in user's home directory.

Attribute Parameters

  • definition: Name attribute, define ruby version. Should be in ruby-build definition list;
  • username: Target user;
  • install_bundler: If true, bundler will be installed. Default is true.

Usage

You must include recipe[ruby_lwrp::default] to your run list or via include_recipe. If you don't want to build ruby or use chruby, you may use recipe[ruby_lwrp::ruby_build] or recipe[ruby_lwrp::chruby] recipes.

Example of ruby 1.9.3-p392 setup:

include_recipe 'ruby_lwrp::default'

ruby_install '1.9.3-p392' do
  action :install
end
ruby_set '1.9.3-p392' do
  action :set
  username 'alice'
end

See fixture cookbook in tests/fixtures/cookbooks.

License and Maintainer

Maintainer:: LLC Express 42 (cookbooks@express42.com)

License:: MIT

Dependent cookbooks

This cookbook has no specified dependencies.

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

1.1.8 (Sep 29, 2015)

  • (New) Add tmp_dir_path attribute for ruby_build lwrp

1.1.7 (Jun 27, 2015)

  • (Fix) Fix compatibility with Chef 12.4.0

1.1.6 (Apr 7, 2015)

  • (New) switched to lightweight resources

1.1.5 (Mar 5, 2015)

  • (New) Rename cookbook name to ruby_lwrp
  • (New) switched to heavy resources

Collaborator Number Metric
            

0.1.8 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.1.8 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

0.1.8 failed this metric

FC059: LWRP provider does not declare use_inline_resources: ruby_lwrp/providers/install.rb:1
FC059: LWRP provider does not declare use_inline_resources: ruby_lwrp/providers/set.rb:1
FC064: Ensure issues_url is set in metadata: ruby_lwrp/metadata.rb:1
FC065: Ensure source_url is set in metadata: ruby_lwrp/metadata.rb:1
FC066: Ensure chef_version is set in metadata: ruby_lwrp/metadata.rb:1
Run with Foodcritic Version 11.1.0 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.1.8 passed this metric

No Binaries Metric
            

0.1.8 passed this metric

Publish Metric
            

0.1.8 passed this metric

Supported Platforms Metric
            

0.1.8 passed this metric

Testing File Metric
            

0.1.8 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.1.8 passed this metric