Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

threatstack (24) Versions 1.7.2

Installs/Configures Threat Stack cloudsight components

Berkshelf/Librarian
Policyfile
Knife
cookbook 'threatstack', '= 1.7.2'
cookbook 'threatstack', '= 1.7.2', :supermarket
knife cookbook site install threatstack
knife cookbook site download threatstack
README
Dependencies
Quality

Threat Stack Cookbook

Build Status Cookbook Version

Chef recipes to deploy the Threat Stack server agent

Requirements

  • chef > 11.0

Platforms

  • Amazon Linux
  • CentOS
  • RedHat
  • Ubuntu

Cookbooks

The following Opscode cookbooks are dependencies:

  • apt
  • yum

Recipes

default

Installs the Threat Stack agent package and register the agent with the service

repo

Sets up the Apt or Yum repo for installing the Threat Stack agent package

Usage

  1. Add this cookbook to your Chef Server or add to your Berksfile cookbook 'threatstack', '~> 1.0.0'

  2. Add your deploy api key. The recommended way is to use an encrypted databag with name and item specified by the corresponding attributes. The cookbook will use the 'deploy_key' value from the databag by default. You can also set the key directly or using a wrapper cookbook in the node['threatstack']['deploy_key'] attribute. Setting the key will disable the encrypted data bag lookup.

  3. Add this recipe to your runlist or include in another recipe

Attributes

node['threatstack']['version'] - Set to pin to a specific Threat Stack agent release version.

node['threatstack']['pkg_action'] - Set to :upgrade if you want to take the latest release (defaults to :install).

node['threatstack']['deploy_key'] - Override this with your deploy key for agent registration.

node['threatstack']['feature_plan'] - Threat Stack feature plan. (values: monitor, investigate, legacy; see: https://www.threatstack.com/plans)

node['threatstack']['data_bag_name'] - Name of the encrypted databag containing Threat Stack secrets

node['threatstack']['data_bag_item'] - Name of the encrypted databag item containing Threat Stack secrets.

node['threatstack']['rulesets'] - Set or override this with an array of rulesets to apply to the node.

node['threatstack']['hostname'] - register the agent in the UI by a specific name (defaults to hostname).

node['threatstack']['agent_config_args'] - array of arguments to enable platform features via cloudsight config.

Encrypted Data Bag Contents

deploy_key - the deploy key for agent registration.

Dependent cookbooks

yum >= 0.0.0
apt >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

1.7.2 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

1.7.2 passed this metric

Foodcritic Metric
            

1.7.2 failed this metric

FC022: Resource condition within loop may not behave as expected: threatstack/recipes/default.rb:206
Run with Foodcritic Version 11.1.0 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

1.7.2 passed this metric

No Binaries Metric
            

1.7.2 passed this metric

Publish Metric
            

1.7.2 passed this metric

Supported Platforms Metric
            

1.7.2 passed this metric

Testing File Metric
            

1.7.2 passed this metric

Version Tag Metric
            

1.7.2 passed this metric