Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the supermarket mailing list.

Select Badges

Select Supported Platforms

RSS

apt (55) Versions 4.0.2

Configures apt and apt services. Ships resources for managing apt repositories

Berkshelf
Librarian
Knife
cookbook 'apt', '~> 4.0.2'
cookbook 'apt', '~> 4.0.2'
knife cookbook site install apt
knife cookbook site download apt
README
Dependencies
Changelog
Quality

apt Cookbook

Build Status Cookbook Version

This cookbook includes recipes to execute apt-get update to ensure the local APT package cache is up to date. There are recipes for managing the apt-cacher-ng caching proxy and proxy clients. It also includes a LWRP for managing APT repositories in /etc/apt/sources.list.d as well as an LWRP for pinning packages via /etc/apt/preferences.d.

Requirements

Platforms

  • Ubuntu 12.04+
  • Debian 7+

May work with or without modification on other Debian derivatives.

Chef

  • Chef 12.1+

Cookbooks

  • None

Recipes

default

This recipe manually updates the timestamp file used to only run apt-get update if the cache is more than one day old.

This recipe should appear first in the run list of Debian or Ubuntu nodes to ensure that the package cache is up to date before managing any package resources with Chef.

This recipe also sets up a local cache directory for preseeding packages.

Including the default recipe on a node that does not support apt (such as Windows) results in a noop.

cacher-client

Configures the node to use the apt-cacher-ng server as a client.

Bypassing the cache

Occasionally you may come across repositories that do not play nicely when the node is using an apt-cacher-ng server. You can configure cacher-client to bypass the server and connect directly to the repository with the cache_bypass attribute.

To do this, you need to override the cache_bypass attribute with an array of repositories, with each array key as the repository URL and value as the protocol to use:

{
    "apt": {
        "cache_bypass": {
            "URL": "PROTOCOL"
        }
    }
}

For example, to prevent caching and directly connect to the repository at download.oracle.com via http:

{
    "apt": {
        "cache_bypass": {
            "download.oracle.com": "http"
        }
    }
}

cacher-ng

Installs the apt-cacher-ng package and service so the system can provide APT caching. You can check the usage report at http://{hostname}:3142/acng-report.html.

If you wish to help the cacher-ng recipe seed itself, you must now explicitly include the cacher-client recipe in your run list after cacher-ng or you will block your ability to install any packages (ie. apt-cacher-ng).

unattended-upgrades

Installs and configures the unattended-upgrades package to provide automatic package updates. This can be configured to upgrade all packages or to just install security updates by setting ['apt']['unattended_upgrades']['allowed_origins'].

To pull just security updates, set origins_patterns to something like ["origin=Ubuntu,archive=trusty-security"] (for Ubuntu trusty) or ["origin=Debian,label=Debian-Security"] (for Debian).

Attributes

General

  • ['apt']['compile_time_update'] - force the default recipe to run apt-get update at compile time.
  • ['apt']['periodic_update_min_delay'] - minimum delay (in seconds) beetween two actual executions of apt-get update by the execute[apt-get-update-periodic] resource, default is '86400' (24 hours)

Caching

  • ['apt']['cacher_ipaddress'] - use a cacher server (or standard proxy server) not available via search
  • ['apt']['cacher_interface'] - interface to connect to the cacher-ng service, no default.
  • ['apt']['cacher_port'] - port for the cacher-ng service (either client or server), default is '3142'
  • ['apt']['cacher_ssl_support'] - indicates whether the cacher supports upstream SSL servers, default is 'false'
  • ['apt']['cacher_dir'] - directory used by cacher-ng service, default is '/var/cache/apt-cacher-ng'
  • ['apt']['cacher-client']['restrict_environment'] - restrict your node to using the apt-cacher-ng server in your Environment, default is 'false'
  • ['apt']['compiletime'] - force the cacher-client recipe to run before other recipes. It forces apt to use the proxy before other recipes run. Useful if your nodes have limited access to public apt repositories. This is overridden if the cacher-ng recipe is in your run list. Default is 'false'
  • ['apt']['cache_bypass'] - array of URLs to bypass the cache. Accepts the URL and protocol to fetch directly from the remote repository and not attempt to cache

Unattended Upgrades

  • ['apt']['unattended_upgrades']['enable'] - enables unattended upgrades, default is false
  • ['apt']['unattended_upgrades']['update_package_lists'] - automatically update package list (apt-get update) daily, default is true
  • ['apt']['unattended_upgrades']['allowed_origins'] - array of allowed apt origins from which to pull automatic upgrades, defaults to a guess at the system's main origin and should almost always be overridden
  • ['apt']['unattended_upgrades']['origins_patterns'] - array of allowed apt origin patterns from which to pull automatic upgrades, defaults to none.
  • ['apt']['unattended_upgrades']['package_blacklist'] - an array of package which should never be automatically upgraded, defaults to none
  • ['apt']['unattended_upgrades']['auto_fix_interrupted_dpkg'] - attempts to repair dpkg state with dpkg --force-confold --configure -a if it exits uncleanly, defaults to false (contrary to the unattended-upgrades default)
  • ['apt']['unattended_upgrades']['minimal_steps'] - Split the upgrade into the smallest possible chunks. This makes the upgrade a bit slower but it has the benefit that shutdown while a upgrade is running is possible (with a small delay). Defaults to false.
  • ['apt']['unattended_upgrades']['install_on_shutdown'] - Install upgrades when the machine is shuting down instead of doing it in the background while the machine is running. This will (obviously) make shutdown slower. Defaults to false.
  • ['apt']['unattended_upgrades']['mail'] - Send email to this address for problems or packages upgrades. Defaults to no email.
  • ['apt']['unattended_upgrades']['mail_only_on_error'] - If set, email will only be set on upgrade errors. Otherwise, an email will be sent after each upgrade. Defaults to true.
  • ['apt']['unattended_upgrades']['remove_unused_dependencies'] Do automatic removal of new unused dependencies after the upgrade. Defaults to false.
  • ['apt']['unattended_upgrades']['automatic_reboot'] - Automatically reboots without confirmation if a restart is required after the upgrade. Defaults to false.
  • ['apt']['unattended_upgrades']['dl_limit'] - Limits the bandwidth used by apt to download packages. Value given as an integer in kb/sec. Defaults to nil (no limit).
  • ['apt']['unattended_upgrades']['random_sleep]' - Wait a random number of seconds up to this value before running daily periodic apt actions. System default is 1800 seconds (30 minutes).

Configuration for APT

  • ['apt']['confd']['install_recommends'] - Consider recommended packages as a dependency for installing. (default: true)
  • ['apt']['confd']['install_suggests'] - Consider suggested packages as a dependency for installing. (default: false)

Libraries

There is an interface_ipaddress method that returns the IP address for a particular host and interface, used by the cacher-client recipe. To enable it on the server use the ['apt']['cacher_interface'] attribute.

Resources/Providers

apt_repository

This LWRP provides an easy way to manage additional APT repositories. Adding a new repository will notify running the execute[apt-get-update] resource immediately.

Actions

  • :add: creates a repository file and builds the repository listing (default)
  • :remove: removes the repository file

Attribute Parameters

  • repo_name: name attribute. The name of the channel to discover
  • uri: the base of the Debian distribution
  • distribution: this is usually your release's codename...ie something like karmic, lucid or maverick
  • components: package groupings... when in doubt use main
  • arch: constrain package to a particular arch like i386, amd64 or even armhf or powerpc. Defaults to nil.
  • trusted: treat all packages from this repository as authenticated regardless of signature
  • deb_src: whether or not to add the repository as a source repo as well - value can be true or false, default false.
  • keyserver: the GPG keyserver where the key for the repo should be retrieved
  • key: if a keyserver is provided, this is assumed to be the fingerprint, otherwise it can be either the URI to the GPG key for the repo, or a cookbook_file.
  • key_proxy: if set, pass the specified proxy via http-proxy= to GPG.
  • cookbook: if key should be a cookbook_file, specify a cookbook where the key is located for files/default. Defaults to nil, so it will use the cookbook where the resource is used.

Examples

Add the Zenoss repo:

apt_repository 'zenoss' do
  uri        'http://dev.zenoss.org/deb'
  components ['main', 'stable']
end

Enable Ubuntu multiverse repositories:

apt_repository 'security-ubuntu-multiverse' do
  uri          'http://security.ubuntu.com/ubuntu'
  distribution 'trusty-security'
  components   ['multiverse']
  deb_src      true
end

Add the Nginx PPA, autodetect the key and repository url:

apt_repository 'nginx-php' do
  uri          'ppa:nginx/stable'
  distribution node['lsb']['codename']
end

Add the JuJu PPA, grab the key from the keyserver, and add source repo:

apt_repository 'juju' do
  uri 'http://ppa.launchpad.net/juju/stable/ubuntu'
  components ['main']
  distribution 'trusty'
  key 'C8068B11'
  keyserver 'keyserver.ubuntu.com'
  action :add
  deb_src true
end

Add the Cloudera Repo of CDH4 packages for Ubuntu 12.04 on AMD64:

apt_repository 'cloudera' do
  uri          'http://archive.cloudera.com/cdh4/ubuntu/precise/amd64/cdh'
  arch         'amd64'
  distribution 'precise-cdh4'
  components   ['contrib']
  key          'http://archive.cloudera.com/debian/archive.key'
end

Remove Zenoss repo:

apt_repository 'zenoss' do
  action :remove
end

apt_preference

This LWRP provides an easy way to pin packages in /etc/apt/preferences.d. Although apt-pinning is quite helpful from time to time please note that Debian does not encourage its use without thorough consideration.

Further information regarding apt-pinning is available via http://wiki.debian.org/AptPreferences.

Actions

  • :add: creates a preferences file under /etc/apt/preferences.d
  • :remove: Removes the file, therefore unpin the package

Attribute Parameters

  • package_name: name attribute. The name of the package
  • glob: Pin by glob() expression or regexp surrounded by /.
  • pin: The package version/repository to pin
  • pin_priority: The pinning priority aka "the highest package version wins"

Examples

Pin libmysqlclient16 to version 5.1.49-3:

apt_preference 'libmysqlclient16' do
  pin          'version 5.1.49-3'
  pin_priority '700'
end

Unpin libmysqlclient16:

apt_preference 'libmysqlclient16' do
  action :remove
end

Pin all packages from dotdeb.org:

apt_preference 'dotdeb' do
  glob         '*'
  pin          'origin packages.dotdeb.org'
  pin_priority '700'
end

Usage

Put recipe[apt] first in the run list. If you have other recipes that you want to use to configure how apt behaves, like new sources, notify the execute resource to run, e.g.:

template '/etc/apt/sources.list.d/my_apt_sources.list' do
  notifies :run, 'execute[apt-get update]', :immediately
end

The above will run during execution phase since it is a normal template resource, and should appear before other package resources that need the sources in the template.

Put recipe[apt::cacher-ng] in the run_list for a server to provide APT caching and add recipe[apt::cacher-client] on the rest of the Debian-based nodes to take advantage of the caching server.

If you want to cleanup unused packages, there is also the apt-get autoclean and apt-get autoremove resources provided for automated cleanup.

License & Authors

Author: Cookbook Engineering Team (cookbooks@chef.io)

Copyright: 2009-2015, Chef Software, Inc.

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

    http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Dependent cookbooks

compat_resource >= 12.10

Contingent cookbooks

7dtd Applicable Versions
CVE-2015-0235 Applicable Versions
aegir Applicable Versions
aegir2 Applicable Versions
aegir3 Applicable Versions
airflow Applicable Versions
ajenti Applicable Versions
akibanserver Applicable Versions
alfresco Applicable Versions
amazon-ecs-agent Applicable Versions
ambari Applicable Versions
anaconda Applicable Versions
apache_spark Applicable Versions
appbox Applicable Versions
appcanary Applicable Versions
application_zf Applicable Versions
applications Applicable Versions
apt-atomic Applicable Versions
apt-chef Applicable Versions
apt-docker Applicable Versions
apt-jenkins Applicable Versions
apt-nginx Applicable Versions
apt-periodic Applicable Versions
apt-zabbix Applicable Versions
aptly Applicable Versions
archiva Applicable Versions
artifact-deployer Applicable Versions
askbot Applicable Versions
asterisk Applicable Versions
atom Applicable Versions
aufs Applicable Versions
auto-update Applicable Versions
automatic_updates Applicable Versions
aws-sdk Applicable Versions
awsclient Applicable Versions
bacula-client Applicable Versions
bamboo Applicable Versions
bamboo-agent Applicable Versions
bapteme Applicable Versions
base Applicable Versions
baseserver Applicable Versions
bash-it Applicable Versions
bastion Applicable Versions
bazaar Applicable Versions
bazel Applicable Versions
beaver Applicable Versions
beef Applicable Versions
berkshelf-api-server Applicable Versions
bigdata Applicable Versions
bind Applicable Versions
bittorrent Applicable Versions
bjn_ruby Applicable Versions
blackfire Applicable Versions
boost-source Applicable Versions
bosun Applicable Versions
boundary-meter Applicable Versions
boundary_meter Applicable Versions
bprobe Applicable Versions
brightbox-ruby Applicable Versions
btm-test Applicable Versions
burp Applicable Versions
cacti Applicable Versions
cafe-core Applicable Versions
carton Applicable Versions
cassandra Applicable Versions
cassandra-dse Applicable Versions
cdap Applicable Versions
ceph Applicable Versions
ceph-chef Applicable Versions
ceph_micro Applicable Versions
cg_mysql Applicable Versions
cgit Applicable Versions
chamber-kibana Applicable Versions
chef-apt-docker Applicable Versions
chef-bareos Applicable Versions
chef-davical Applicable Versions
chef-mongodb Applicable Versions
chef_crowd Applicable Versions
chef_eye Applicable Versions
chef_install_configure_collectd Applicable Versions
chef_newrelic_server Applicable Versions
chef_nginx Applicable Versions
chef_ruby Applicable Versions
chef_rvm Applicable Versions
chef_vault_pki Applicable Versions
chrome Applicable Versions
chronos Applicable Versions
chruby-build Applicable Versions
cifs Applicable Versions
clamav Applicable Versions
cloudfoundry Applicable Versions
cloudinsight-agent Applicable Versions
cloudpassage Applicable Versions
cloudstack Applicable Versions
cobblerd Applicable Versions
common_linux Applicable Versions
composer Applicable Versions
confluent-cookbook Applicable Versions
conjur Applicable Versions
container Applicable Versions
containership Applicable Versions
coopr Applicable Versions
couchbase Applicable Versions
couchbase-ng Applicable Versions
cronapt Applicable Versions
crowd Applicable Versions
crypto-coin Applicable Versions
cuckoo Applicable Versions
cyclesafe_chef Applicable Versions
darkice-rpi Applicable Versions
datadog Applicable Versions
debian Applicable Versions
deis Applicable Versions
device-mapper Applicable Versions
devops_basic Applicable Versions
devops_library Applicable Versions
devstack Applicable Versions
diamond Applicable Versions
dnsimple Applicable Versions
dnsmasq-local Applicable Versions
docker Applicable Versions
docker-registry2 Applicable Versions
docker_registry Applicable Versions
dokku Applicable Versions
dotdeb Applicable Versions
dotdeb_repo Applicable Versions
dotnetcore Applicable Versions
drill Applicable Versions
dropwizard Applicable Versions
druid-example Applicable Versions
dse Applicable Versions
dspam Applicable Versions
duosecurity Applicable Versions
ejabberd Applicable Versions
elasticsearch Applicable Versions
elasticsearch-cluster Applicable Versions
elasticsearch-curator Applicable Versions
elasticsearch-ng Applicable Versions
elixir Applicable Versions
elk Applicable Versions
elkstack Applicable Versions
emacs24 Applicable Versions
enstratius_agent_proxy Applicable Versions
entropy Applicable Versions
equivs Applicable Versions
erlang Applicable Versions
errbit Applicable Versions
et_elk Applicable Versions
et_fog Applicable Versions
et_haproxy Applicable Versions
et_mesos Applicable Versions
etcd-v2 Applicable Versions
eulipion-slate Applicable Versions
fabio Applicable Versions
factorio Applicable Versions
fieri Applicable Versions
filebeat Applicable Versions
filezilla Applicable Versions
flapjack Applicable Versions
flume Applicable Versions
flyway-cli Applicable Versions
fog_gem Applicable Versions
foreman Applicable Versions
formatron_beats Applicable Versions
formatron_common Applicable Versions
formatron_elasticsearch Applicable Versions
formatron_erlang Applicable Versions
formatron_grafana Applicable Versions
formatron_logstash Applicable Versions
formatron_rabbitmq Applicable Versions
formatron_sensu Applicable Versions
freeswitch Applicable Versions
freetds Applicable Versions
freight Applicable Versions
frog Applicable Versions
fuse Applicable Versions
fusioninventory-agent Applicable Versions
gce_gcsfuse Applicable Versions
gdebi Applicable Versions
gearman Applicable Versions
gecode Applicable Versions
gem_installation Applicable Versions
gemirro Applicable Versions
gflags Applicable Versions
ghost Applicable Versions
gimp Applicable Versions
git-annex Applicable Versions
git_ppa Applicable Versions
github_connector Applicable Versions
gitlab Applicable Versions
gitlab-shell Applicable Versions
gitlab_runner Applicable Versions
gluster Applicable Versions
go_cd Applicable Versions
goaccess Applicable Versions
gocd Applicable Versions
gogs Applicable Versions
google-chrome Applicable Versions
gotcms Applicable Versions
gozer Applicable Versions
grafana Applicable Versions
grafana2 Applicable Versions
graylog Applicable Versions
graylog2 Applicable Versions
grinder Applicable Versions
grive Applicable Versions
gruyere Applicable Versions
guardian Applicable Versions
hadoop Applicable Versions
hadoop_cluster Applicable Versions
haproxy-ng Applicable Versions
harden Applicable Versions
harstorage Applicable Versions
hbase_cluster Applicable Versions
hclam Applicable Versions
hello_world_circleci_deploy_example Applicable Versions
hem Applicable Versions
hhvm Applicable Versions
hhvm3 Applicable Versions
hipchat_client Applicable Versions
hockeypuck Applicable Versions
hollandbackup Applicable Versions
hwraid Applicable Versions
ice Applicable Versions
icinga-ng Applicable Versions
icinga2 Applicable Versions
il-base Applicable Versions
influxdb Applicable Versions
iptables_web Applicable Versions
ipynb Applicable Versions
java Applicable Versions
java-service Applicable Versions
java-snapshot Applicable Versions
jboss7 Applicable Versions
jenkins Applicable Versions
jenkins-php Applicable Versions
jenkins-repo Applicable Versions
jenkins_build Applicable Versions
jenkins_drupal Applicable Versions
jenkins_utils Applicable Versions
jenkinsstack Applicable Versions
jenv Applicable Versions
jetbrains_license_server Applicable Versions
jmeter Applicable Versions
justniffer Applicable Versions
kafka-manager Applicable Versions
kafka_broker Applicable Versions
kali Applicable Versions
kamailio Applicable Versions
kismet Applicable Versions
kodi Applicable Versions
komodo-edit Applicable Versions
kvexpress Applicable Versions
kvm Applicable Versions
libarchive Applicable Versions
libbzip2 Applicable Versions
libguestfs Applicable Versions
libmysqlclient Applicable Versions
librato Applicable Versions
libreoffice Applicable Versions
libxml2 Applicable Versions
libyaml Applicable Versions
linode Applicable Versions
linux-basic Applicable Versions
linux-gamer Applicable Versions
linux-tweak Applicable Versions
linux_basic Applicable Versions
lita Applicable Versions
lmctfy Applicable Versions
logentries Applicable Versions
logentries_agent Applicable Versions
logentries_ng Applicable Versions
loggly_rsyslog_ng Applicable Versions
logstash-forwarder Applicable Versions
logstash_forwarder Applicable Versions
lshw Applicable Versions
lxc-web-panel Applicable Versions
lxd Applicable Versions
maas Applicable Versions
mackerel-agent Applicable Versions
magento Applicable Versions
magentostack Applicable Versions
marathon Applicable Versions
mariadb Applicable Versions
mattermost Applicable Versions
mcollective Applicable Versions
mcrouter Applicable Versions
memcached-cookbook Applicable Versions
mesos Applicable Versions
met-jenkins Applicable Versions
meteor Applicable Versions
minecraft Applicable Versions
minecraft-basic Applicable Versions
mlocate Applicable Versions
mod_security Applicable Versions
mongodb Applicable Versions
mongodb-10gen Applicable Versions
mongodb3 Applicable Versions
monit-ng Applicable Versions
monit_wrapper Applicable Versions
monkey Applicable Versions
mono Applicable Versions
mono3 Applicable Versions
mono4 Applicable Versions
mosh Applicable Versions
mount_cifs Applicable Versions
mroonga Applicable Versions
mrpapp Applicable Versions
mu Applicable Versions
mule Applicable Versions
murmur Applicable Versions
mw_server_base Applicable Versions
mysql-multi Applicable Versions
mysql-simple Applicable Versions
mysql_role Applicable Versions
mysqld Applicable Versions
mysqler Applicable Versions
mythtv Applicable Versions
nagios3 Applicable Versions
ndenv Applicable Versions
neo4j Applicable Versions
nephology Applicable Versions
netdevops Applicable Versions
netselect Applicable Versions
newrelic Applicable Versions
newrelic-ng Applicable Versions
newrelic-sysmond Applicable Versions
newrelic_meetme_plugin Applicable Versions
nftables Applicable Versions
nginx Applicable Versions
nginx-repo Applicable Versions
nginx_passenger Applicable Versions
nginx_resources Applicable Versions
nmdbase Applicable Versions
nodebrew Applicable Versions
nodejs Applicable Versions
nodestack Applicable Versions
ntp_cluster Applicable Versions
oc-id Applicable Versions
omnibus Applicable Versions
oneapm-ci-agent Applicable Versions
open_resty Applicable Versions
opencpu Applicable Versions
opencv Applicable Versions
opendj-openam Applicable Versions
openfortivpn Applicable Versions
openhab Applicable Versions
openjdk Applicable Versions
opennebula_ng Applicable Versions
openresty Applicable Versions
openstack Applicable Versions
openstack-clients Applicable Versions
openstack-mistral Applicable Versions
openvas Applicable Versions
opera Applicable Versions
opsmatic Applicable Versions
opsview Applicable Versions
opt-modules Applicable Versions
optipng Applicable Versions
orientdb Applicable Versions
os-hardening Applicable Versions
osquery Applicable Versions
osrm Applicable Versions
osslsigncode Applicable Versions
owncloud Applicable Versions
packagecloud Applicable Versions
packetbeat Applicable Versions
pam-ssh-agent-auth Applicable Versions
paramount Applicable Versions
patchman Applicable Versions
percona Applicable Versions
percona-multi Applicable Versions
percona-toolkit Applicable Versions
perforce Applicable Versions
pertino Applicable Versions
pg-multi Applicable Versions
pgbadger Applicable Versions
phabricator Applicable Versions
php Applicable Versions
php-fpm Applicable Versions
php5_ppa Applicable Versions
phpbb Applicable Versions
phpenv Applicable Versions
phpstack Applicable Versions
pig Applicable Versions
pipeline Applicable Versions
pita Applicable Versions
pkg-build Applicable Versions
platformstack Applicable Versions
playonlinux Applicable Versions
poise-ruby Applicable Versions
postgis Applicable Versions
postgresql Applicable Versions
postgresql91 Applicable Versions
postgresql_lwrp Applicable Versions
postgresql_studio Applicable Versions
poweradmin Applicable Versions
pritunl Applicable Versions
prometheus Applicable Versions
prose Applicable Versions
prosody Applicable Versions
protobuf Applicable Versions
protractor Applicable Versions
ps3mediaserver Applicable Versions
puncha-kibana Applicable Versions
puppet Applicable Versions
pxe Applicable Versions
pxe_dust Applicable Versions
pythonstack Applicable Versions
qgis Applicable Versions
qpdf Applicable Versions
r-project Applicable Versions
rabbitmq Applicable Versions
rackops_rolebook Applicable Versions
rackspace_apache_php Applicable Versions
rackspace_cloud_monitoring Applicable Versions
rackspace_cloudbackup Applicable Versions
rackspace_gluster Applicable Versions
rackspace_iptables Applicable Versions
rackspace_monitoring Applicable Versions
rackspace_nginx_php Applicable Versions
rackspace_support Applicable Versions
rbenv Applicable Versions
realmd-sssd Applicable Versions
recognizer Applicable Versions
redis-cookbook Applicable Versions
redis-multi Applicable Versions
repos Applicable Versions
repository Applicable Versions
request_tracker Applicable Versions
rethinkdb Applicable Versions
riak Applicable Versions
riak-cs Applicable Versions
riemann2 Applicable Versions
rippled Applicable Versions
rkhunter Applicable Versions
rkt Applicable Versions
robot Applicable Versions
ros Applicable Versions
roundcube Applicable Versions
rsyslog_ng Applicable Versions
ruby-enterprise-install Applicable Versions
ruby-ng Applicable Versions
ruby_install Applicable Versions
ruby_pkg Applicable Versions
ruby_rvm Applicable Versions
rundeck-alt Applicable Versions
rvm Applicable Versions
rvm_fw Applicable Versions
sai_nrpe Applicable Versions
sai_sensu Applicable Versions
salt Applicable Versions
samhain Applicable Versions
sanitize Applicable Versions
scipy Applicable Versions
scout Applicable Versions
search_helpers Applicable Versions
selenium_grid Applicable Versions
sensu Applicable Versions
sensu_admin Applicable Versions
sensu_spec Applicable Versions
serverdensity Applicable Versions
shinken Applicable Versions
sikulix Applicable Versions
simple-scala-sbt Applicable Versions
simple_consul_alerts Applicable Versions
simple_passenger Applicable Versions
singularity Applicable Versions
sinopia Applicable Versions
sk_ruby Applicable Versions
skype-app Applicable Versions
skype-daemon Applicable Versions
soa_tools Applicable Versions
sogo Applicable Versions
solr Applicable Versions
solrcloud Applicable Versions
sonarr Applicable Versions
sox_mp3 Applicable Versions
spartan_loggly_rsyslog Applicable Versions
sphinx Applicable Versions
spigot Applicable Versions
spinen-artifactory Applicable Versions
spotify Applicable Versions
sshd-service Applicable Versions
stack-base Applicable Versions
stack-marathon Applicable Versions
stack_commons Applicable Versions
stackstorm Applicable Versions
stackup-base Applicable Versions
steam Applicable Versions
storj Applicable Versions
storm-cluster Applicable Versions
stow Applicable Versions
strongloop Applicable Versions
stumpwm Applicable Versions
sublime-text Applicable Versions
sudo_consul Applicable Versions
sudo_elastic Applicable Versions
sudo_logstash Applicable Versions
sugarcrm-ce Applicable Versions
supermarket Applicable Versions
swftools Applicable Versions
sysdig Applicable Versions
system Applicable Versions
takipi Applicable Versions
taskwarrior Applicable Versions
taurus Applicable Versions
td-agent Applicable Versions
telegraf Applicable Versions
tentacool Applicable Versions
terraria Applicable Versions
threatstack Applicable Versions
thruk Applicable Versions
thumbor Applicable Versions
thumbor_ng Applicable Versions
tideways Applicable Versions
tinc Applicable Versions
tomcat-all Applicable Versions
tomcat-openam Applicable Versions
tomcat-solr Applicable Versions
tomoyo Applicable Versions
tonicdns Applicable Versions
topbeat Applicable Versions
tor-full Applicable Versions
toran Applicable Versions
trafficserver Applicable Versions
tungsten Applicable Versions
tunnel Applicable Versions
tutum Applicable Versions
twemproxy Applicable Versions
twindb-repo Applicable Versions
typesafe-stack Applicable Versions
ubuntu Applicable Versions
uchiwa Applicable Versions
unattended-upgrades Applicable Versions
unifi Applicable Versions
unifi-video Applicable Versions
unimrcp Applicable Versions
ut_base Applicable Versions
ut_workstation Applicable Versions
vagabond Applicable Versions
vagrant-node-simple Applicable Versions
varnish Applicable Versions
varnish_ng Applicable Versions
varnishd Applicable Versions
vim-go Applicable Versions
virtualbox Applicable Versions
vlc Applicable Versions
vs_code Applicable Versions
vsphere_perl_sdk Applicable Versions
vxfld Applicable Versions
webgoat Applicable Versions
webmin Applicable Versions
webobjects Applicable Versions
wildfly Applicable Versions
wkhtmltopdf Applicable Versions
wkhtmltopdf-update Applicable Versions
worldcommunitygrid Applicable Versions
x2go-client Applicable Versions
x2go-server Applicable Versions
xrdp Applicable Versions
xvfb Applicable Versions
zabbix-agent Applicable Versions
zabbix3 Applicable Versions
zabbix_lwrp Applicable Versions
zabbix_ng Applicable Versions
zend Applicable Versions
zend-server Applicable Versions
zendserver Applicable Versions
zenoss Applicable Versions
zentyal Applicable Versions
zeromq Applicable Versions
zfs_linux Applicable Versions
zncrypt Applicable Versions
zookeeper Applicable Versions
zookeeper_cluster Applicable Versions
zookeeperd Applicable Versions
zotonic Applicable Versions
zshell Applicable Versions

apt Cookbook CHANGELOG

This file is used to list changes made in each version of the apt cookbook.

4.0.2 (2016-08-13)

  • The cookbook requires Chef 12.1+ not 12.0. Update docs
  • Test on Chef 12.1 to ensure compatibility
  • Restore compatibility with Chef < 12.4

4.0.1 (2016-06-21)

  • Fix bug that prevented adding the cookbook to non Debian/Ubuntu nodes without chef run failures

4.0.0 (2016-06-02)

This cookbook now requires Chef 12. If you require Chef 11 compatibility you will need to pin to the 3.X cookbook version

  • The apt-get update logic in the default recipe has been converted to apt_update custom resource and compat_resource cookbook has been added for backwards compatibility with all Chef 12.X releases. In addition this resource is now included in core chef-client and the cookbook will use the built-in resource if available
  • Added support for the unattended-upgrade RandomSleep configuration feature
  • Added support for the unattended-upgrade Unattended-Upgrade::Origins-Pattern configuration feature
  • Added Chefspec matchers for apt_update
  • Fixed apt_repository documentation to correctly reflect the deb_src property

3.0.0 (2016-03-01)

  • Removed Chef 10 compatibility code. This cookbook requires Chef 11 or greater now
  • The default recipe will no longer create /etc/apt/ and other directories on non-Debian based systems
  • Updated the autoremove command in the default recipe to run in non-interactive mode
  • Added CentOS 7 to Test Kitchenwith tests to ensure we don't create any files on RHEL or other non-Debian hosts
  • Updated Chefspec to 4.X format
  • Properly mock the existence of apt for the Chefspec runs so they don't just skip over the resources
  • Fixed lwrp test kitchen tests to pass
  • Resolved or disabled all Rubocop warnings
  • Enabled testing in Travis CI
  • Removed Apt Cacher NG support for Ubuntu 10.04 and Debian 6.X as they are both deprecated
  • Fixed + signs in packages names with the preference LWRP being rejected

v2.9.2

  • # 168 Adding guard to package resource.

v2.9.1

  • Adding package apt-transport-https to default.rb

v2.9.0

  • Add sensitive flag for apt_repositories
  • Enable installation of recommended or suggested packages
  • Tidy up apt-get update logic
  • Fixing not_if guard on ruby_block[validate-key #{key}]

v2.8.2 (2015-08-24)

  • Fix removal of apt_preferences

v2.8.1 (2015-08-18)

  • Handle keyservers as URLs and bare hostnames

v2.8.0 (2015-08-18)

  • Access keyservers on port 80
  • Adds key_proxy as LWRP attribute for apt_repository
  • Fix wildcard glob preferences files
  • Fix text output verification for non en_US locales
  • Quote repo URLs to deal with spaces

v2.7.0 (2015-03-23)

  • Support Debian 8.0
  • Filename verification for LWRPs
  • Support SSL enabled apt repositories

v2.6.1 (2014-12-29)

  • Remove old preference files without .pref extension from previous versions

v2.6.0 (2014-09-09)

  • Always update on first run - check
  • Adding ppa support for apt_repository

v2.5.3 (2014-08-14)

  • # 87 - Improve default settings, account for non-linux platforms

v2.5.2 (2014-08-14)

  • Fully restore 2.3.10 behaviour

v2.5.1 (2014-08-14)

  • fix breakage introduced in apt 2.5.0

v2.5.0 (2014-08-12)

  • Add unattended-upgrades recipe
  • Only update the cache for the created repository
  • Added ChefSpec matchers and default_action for resources
  • Avoid cloning resource attributes
  • Minor documentation updates

v2.4.0 (2014-05-15)

  • [COOK-4534]: Add option to update apt cache at compile time

v2.3.10 (2014-04-23)

  • [COOK-4512] Bugfix: Use empty PATH if PATH is nil

v2.3.8 (2014-02-14)

Bug

v2.3.6

  • [COOK-4154] - Add chefspec matchers.rb file to apt cookbook
  • [COOK-4102] - Only index created repository

v2.3.6

  • [COOK-4154] - Add chefspec matchers.rb file to apt cookbook
  • [COOK-4102] - Only index created repository

v2.3.4

No change. Version bump for toolchain sanity

v2.3.2

  • [COOK-3905] apt-get-update-periodic: configuration for the update period
  • Updating style for rubocops
  • Updating test-kitchen harness

v2.3.0

Bug

  • COOK-3812 - Add a way to bypass the apt existence check

Improvement

  • COOK-3567 - Allow users to bypass apt-cache via attributes

v2.2.1

Improvement

  • COOK-664 - Check platform before running apt-specific commands

v2.2.0

Bug

  • COOK-3707 - multiple nics confuse apt::cacher-client

v2.1.2

Improvement

  • COOK-3551 - Allow user to set up a trusted APT repository

v2.1.1

Bug

  • COOK-1856 - Match GPG keys without case sensitivity

v2.1.0

  • [COOK-3426]: cacher-ng fails with restrict_environment set to true
  • [COOK-2859]: cacher-client executes out of order
  • [COOK-3052]: Long GPG keys are downloaded on every run
  • [COOK-1856]: apt cookbook should match keys without case sensitivity
  • [COOK-3255]: Attribute name incorrect in README
  • [COOK-3225]: Call use_inline_resources only if defined
  • [COOK-3386]: Cache dir for apt-cacher-ng
  • [COOK-3291]: apt_repository: enable usage of a keyserver on port 80
  • Greatly expanded test coverage with ChefSpec and Test-Kitchen

v2.0.0

Bug

  • [COOK-2258]: apt: LWRP results in error under why-run mode in apt 1.9.0 cookbook

v1.10.0

Improvement

  • [COOK-2885]: Improvements for apt cache server search

Bug

  • [COOK-2441]: Apt recipe broken in new chef version
  • [COOK-2660]: Create Debian 6.0 "squeeze" specific template for
  • apt-cacher-ng

v1.9.2

  • [COOK-2631] - Create Ubuntu 10.04 specific template for apt-cacher-ng

v1.9.0

  • [COOK-2185] - Proxy for apt-key
  • [COOK-2338] - Support pinning by glob() or regexp

v1.8.4

  • [COOK-2171] - Update README to clarify required Chef version: 10.18.0
  • or higher.

v1.8.2

  • [COOK-2112] - need [] around "arch" in sources.list entries
  • [COOK-2171] - fixes a regression in the notification

v1.8.0

  • [COOK-2143] - Allow for a custom cacher-ng port
  • [COOK-2171] - On apt_repository.run_action(:add) the source file
  • is not created.
  • [COOK-2184] - apt::cacher-ng, use cacher_port attribute in
  • acng.conf

v1.7.0

  • [COOK-2082] - add "arch" parameter to apt_repository LWRP

v1.6.0

  • [COOK-1893] - apt_preference use "package_name" resource instead of "name"
  • [COOK-1894] - change filename for sources.list.d files
  • [COOK-1914] - Wrong dir permissions for /etc/apt/preferences.d/
  • [COOK-1942] - README.md has wrong name for the keyserver attribute
  • [COOK-2019] - create 01proxy before any other apt-get updates get executed

v1.5.2

  • [COOK-1682] - use template instead of file resource in apt::cacher-client
  • [COOK-1875] - cacher-client should be Environment-aware

V1.5.0

  • [COOK-1500] - Avoid triggering apt-get update
  • [COOK-1548] - Add execute commands for autoclean and autoremove
  • [COOK-1591] - Setting up the apt proxy should leave https
  • connections direct
  • [COOK-1596] - execute[apt-get-update-periodic] never runs
  • [COOK-1762] - create /etc/apt/preferences.d directory
  • [COOK-1776] - apt key check isn't idempotent

v1.4.8

  • Adds test-kitchen support
  • [COOK-1435] - repository lwrp is not idempotent with http key

v1.4.6

  • [COOK-1530] - apt_repository isn't aware of update-success-stamp
  • file (also reverts COOK-1382 patch).

v1.4.4

  • [COOK-1229] - Allow cacher IP to be set manually in non-Chef Solo
  • environments
  • [COOK-1530] - Immediately update apt-cache when sources.list file is dropped off

v1.4.2

  • [COOK-1155] - LWRP for apt pinning

v1.4.0

  • [COOK-889] - overwrite existing repo source files
  • [COOK-921] - optionally use cookbook_file or remote_file for key
  • [COOK-1032] - fixes problem with apt repository key installation

Foodcritic Metric

4.0.2 passed Foodcritic.

Collaborators Metric

4.0.2 passed the Collaborator Metric with 7 collaborators.