Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

postgis (4) Versions 0.3.0

Installs/Configures postgis Postgresql extension

Berkshelf/Librarian
Policyfile
Knife
cookbook 'postgis', '~> 0.3.0'
cookbook 'postgis', '~> 0.3.0', :supermarket
knife cookbook site install postgis
knife cookbook site download postgis
README
Dependencies
Quality 56%

Description

Build Status

The postgis cookbook installs and configures the Postgis Postgresql extension and creates a GIS enabled database template.

Requirements

Platform:

  • Ubuntu
  • Fedora
  • Centos
  • Rhel

Cookbooks:

  • apt
  • yum
  • postgresql

Attributes

  • node['postgis']['template_name'] - Postgis Template Database: The name of the gis database template. Set to nil to disable the creation of the template. Defaults to template_postgis.
  • node['postgis']['locale'] - Postgis Template locale: The locale of the database. Defaults to en_US.utf8.

Recipes

postgis::default

Install the Postgis binaries and create the template.

Note: this includes the postgresql::server after installing the postgis binaries.

Locale

It should be noted that it is best setup the locale so that the encoding is the desired database encoding prior to including the recipe. Typically this is set via a snippet such as;

node.override['locale']['lang'] = 'en_AU.UTF-8'
include_recipe 'locale::default'

include_recipe 'postgis::default'

License and Maintainer

Maintainer:: Peter Donald (peter@realityforge.org)

License:: Apache 2.0

Dependent cookbooks

postgresql >= 0.0.0
yum >= 0.0.0
apt >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

0.3.0 failed this metric

Failure: Cookbook has 1 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.3.0 passed this metric

Foodcritic Metric
            

0.3.0 failed this metric

FC064: Ensure issues_url is set in metadata: postgis/metadata.rb:1
FC065: Ensure source_url is set in metadata: postgis/metadata.rb:1
FC066: Ensure chef_version is set in metadata: postgis/metadata.rb:1
FC069: Ensure standardized license defined in metadata: postgis/metadata.rb:1
FC070: Ensure supports metadata defines valid platforms: postgis/metadata.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.3.0 passed this metric

No Binaries Metric
            

0.3.0 failed this metric

Failure: Cookbook should not contain binaries. Found:
postgis/files/default/314DF160.key
postgis/files/default/DAF764E2.key

Publish Metric
            

0.3.0 passed this metric

Supported Platforms Metric
            

0.3.0 passed this metric

Testing File Metric
            

0.3.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.3.0 passed this metric