Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

The node cookbook has been deprecated

The node cookbook has been deprecated and is no longer being maintained by its authors. Use of the node cookbook is no longer recommended. You may find that the nodejs cookbook is a suitable alternative.

RSS

node (9) Versions 1.1.3

Installs/Configures node, npm and node server providers

Berkshelf/Librarian
Policyfile
Knife
cookbook 'node', '~> 1.1.3'
cookbook 'node', '~> 1.1.3', :supermarket
knife cookbook site install node
knife cookbook site download node
README
Dependencies
Quality 33%
= DEPRECATED: This repo is no longer the recommended cookbook to use for installing and maintaining node and npm. The 'nodejs' cookbook here would be the one to use: https://github.com/redguide/nodejs/ = DESCRIPTION: This cookbook will deploy node and npm (node package manager) to your system. It also defines providers to install/uninstall node module and start/stop/restart node servers. * homepage : https://github.com/digitalbutter/cookbook-node = REQUIREMENTS: * a working git framework (for example provided by Opscode git cookbook) Tested on ubuntu. Should work on other system with upstart. = ATTRIBUTES: * node/revision : indicates which revision to install. Default is the latest ('HEAD'). Since node evolves very quickly and is not always that stable, you might want to set it to a stable version (for example 'v0.4.3') * `node[:node][:packages]` - An array of npm packages to be installed globally = USAGE: Include the node recipe to download, compile and install node along with npm. Optionally, you can add NPM packages by creating a packages array: ``` default_attributes({ node: { packages: ['coffee-script', 'lineman'] } }) ``` == defines: +node_server+ provider to start/stop server. The following example will start a provided script with node. Logs can be found in /var/log/node-my_node_server.log. node_server "my_node_server" do script "/path/to/your/node/script.js" # mandatory user "my_user" # default : nodejs dependency ["required","node","modules"] # default []. Will be installed with npm before starting the server args "arguments for your script" # default "" init_style :runit # default - by platform. Spported values: :upstart, :init, :runit action :start # Will start a node server. In [stop,start,restart], default :start end +node_npm+ provider to manage nodejs modules. The following example will install the connect module for node. node_npm "connect" do action :install end = LICENSE & AUTHOR: Author:: * Emmanuel Prochasson (<emmanuel@tikibooth.com>) * Ed Bosher (<edbo@tikibooth.com>) Contributor: * Jon Wood (<jon@blankpad.net>) Copyright:: 2011, Tikibooth Limited Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

Collaborator Number Metric
            

1.1.3 failed this metric

Failure: Cookbook has 1 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

1.1.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

1.1.3 failed this metric

FC009: Resource attribute not recognised: node/providers/server.rb:60
FC016: LWRP does not declare a default action: node/resources/nodejs.rb:1
FC017: LWRP does not notify when updated: node/providers/nodejs.rb:1
FC017: LWRP does not notify when updated: node/providers/nodejs.rb:33
FC017: LWRP does not notify when updated: node/providers/nodejs.rb:39
FC017: LWRP does not notify when updated: node/providers/npm.rb:5
FC017: LWRP does not notify when updated: node/providers/npm.rb:23
FC017: LWRP does not notify when updated: node/providers/npm.rb:34
FC017: LWRP does not notify when updated: node/providers/npm.rb:42
FC017: LWRP does not notify when updated: node/providers/server.rb:7
FC017: LWRP does not notify when updated: node/providers/server.rb:81
FC017: LWRP does not notify when updated: node/providers/server.rb:88
FC017: LWRP does not notify when updated: node/providers/server.rb:95
FC017: LWRP does not notify when updated: node/providers/server.rb:102
FC034: Unused template variables: node/templates/debian/init.sh.erb:1
FC039: Node method cannot be accessed with key: node/attributes/default.rb:1
FC039: Node method cannot be accessed with key: node/attributes/default.rb:2
FC039: Node method cannot be accessed with key: node/attributes/default.rb:3
FC039: Node method cannot be accessed with key: node/attributes/default.rb:4
FC039: Node method cannot be accessed with key: node/providers/server.rb:20
FC039: Node method cannot be accessed with key: node/recipes/default.rb:34
FC039: Node method cannot be accessed with key: node/recipes/default.rb:35
FC039: Node method cannot be accessed with key: node/recipes/default.rb:57
FC039: Node method cannot be accessed with key: node/recipes/packages.rb:20
FC039: Node method cannot be accessed with key: node/resources/server.rb:15
FC059: LWRP provider does not declare use_inline_resources: node/providers/nodejs.rb:1
FC059: LWRP provider does not declare use_inline_resources: node/providers/npm.rb:1
FC059: LWRP provider does not declare use_inline_resources: node/providers/server.rb:1
FC064: Ensure issues_url is set in metadata: node/metadata.rb:1
FC065: Ensure source_url is set in metadata: node/metadata.rb:1
FC066: Ensure chef_version is set in metadata: node/metadata.rb:1
FC069: Ensure standardized license defined in metadata: node/metadata.rb:1
FC072: Metadata should not contain "attribute" keyword: node/metadata.rb:1
FC074: LWRP should use DSL to define resource's default action: node/resources/server.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

1.1.3 passed this metric

No Binaries Metric
            

1.1.3 passed this metric

Publish Metric
            

1.1.3 failed this metric

node is deprecated

Supported Platforms Metric
            

1.1.3 passed this metric

Testing File Metric
            

1.1.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

1.1.3 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number