Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

Lynis (4) Versions 1.0.1

Installs/Configures Lynis

Berkshelf/Librarian
Policyfile
Knife
cookbook 'Lynis', '~> 1.0.1'
cookbook 'Lynis', '~> 1.0.1', :supermarket
knife cookbook site install Lynis
knife cookbook site download Lynis
README
Dependencies
Changelog
Quality 33%

Lynis Cookbook

This cookbook installs Lynis and can also execute the security audit report if instructed.

What is Lynis?

Lynis is a software component to audit Unix based systems. Lynis Enterprise uses Lynis to gather data from machines. Additionally it has an administration interface, reporting, implementation plans, hardening guidance and more. For more details, refer to - https://cisofy.com/lynis-enterprise/

Requirements

Depends on cookbooks * apt * apt-transport-https

Platforms

  • Tested on ubuntu-16.04 only

Chef

  • Chef 12.0 or later

Attributes

None

Usage

Lynis::default

This would install lynis and execute the audit report

e.g. Just include Lynis in your node's run_list:

{
  "name":"my_node",
  "run_list": [
    "recipe[Lynis]"
  ]
}

Lynis::install

This would install lynis only

e.g. Just include Lynis::install in your node's run_list:

{
  "name":"my_node",
  "run_list": [
    "recipe[Lynis::install]"
  ]
}

Lynis::audit

This would execute the security audit report. It would also check if the lynis package is installed. The report is generated by default under /var/log/. The 2 report files are - * lynis.log * lynis-report.dat

e.g. Just include Lynis::audit in your node's run_list:

{
  "name":"my_node",
  "run_list": [
    "recipe[Lynis::audit]"
  ]
}

Contributing

  1. Create a branch of the repository on Bitbucket
  2. Create a named feature branch (like add_component_x)
  3. Write your change
  4. Write tests for your change (if applicable)
  5. Run the tests, ensuring they all pass
  6. Submit a Pull Request using Bitbucket

License and Authors

Authors: Mrinal Mukherjee

Dependent cookbooks

apt ~> 4.0.2

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Lynis CHANGELOG

This file is used to list changes made in each version of the Lynis cookbook.

0.1.0

  • [Mrinal Mukherjee] - Initial release of Lynis

0.2.0

  • [Mrinal Mukherjee] - Updated the licence to GPL since Lynis is released as GPL

1.0.0

  • [Mrinal Mukherjee] - Refactored the code base and tests. Updated the licence

1.0.1

  • [Mrinal Mukherjee] - Replaced bitbucket with github, updated changelog. Rubocop fixes. Bumped up the version

Collaborator Number Metric
            

1.0.1 passed this metric

Contributing File Metric
            

1.0.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

1.0.1 failed this metric

FC064: Ensure issues_url is set in metadata: Lynis/metadata.rb:1
FC065: Ensure source_url is set in metadata: Lynis/metadata.rb:1
FC066: Ensure chef_version is set in metadata: Lynis/metadata.rb:1
FC067: Ensure at least one platform supported in metadata: Lynis/metadata.rb:1
FC069: Ensure standardized license defined in metadata: Lynis/metadata.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

1.0.1 failed this metric

Lynis does not have a valid open source license.
Acceptable licenses include Apache-2.0, apachev2, Apache 2.0, MIT, mit, GPL-2.0, gplv2, GNU Public License 2.0, GPL-3.0, gplv3, GNU Public License 3.0.

No Binaries Metric
            

1.0.1 passed this metric

Publish Metric
            

1.0.1 passed this metric

Supported Platforms Metric
            

1.0.1 failed this metric

Lynis should declare what platform(s) it supports.

Testing File Metric
            

1.0.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

1.0.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number