Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

dnsimple (20) Versions 1.2.0

Provides Chef Resource for automating DNS configuration with DNSimple

Berkshelf/Librarian
Policyfile
Knife
cookbook 'dnsimple', '= 1.2.0'
cookbook 'dnsimple', '= 1.2.0', :supermarket
knife cookbook site install dnsimple
knife cookbook site download dnsimple
README
Dependencies
Changelog
Quality

Description

A Light-weight Resource and Provider (LWRP) supporting automatic DNS configuration via DNSimple's API.

Build Status

Requirements

  • A DNSimple account at https://dnsimple.com
  • Chef 11 or newer (Feel free to send a pull request for Chef 10.x support)

Known issues

  • This cookbook currently cannot work with Chef 12.1.0 due to a dependency conflict with the 'net-scp' and 'net-ssh' dependnecies of the fog gem. If you have a solution for this, please send a Pull Request.

Attributes

All attributes are nil, or false by default.

  • node[:dnsimple][:username]: Your DNSimple login username.
  • node[:dnsimple][:password]: Your DNSimple login password.
  • node[:dnsimple][:domain]: The domain that this node should use.
  • node[:dnsimple][:test]: Unused at this time.

Resources/Providers

dnsimple_record

Manage a DNS resource record through the DNSimple API. This LWRP uses the fog Ruby library to connect and use the API.

Actions:

| Action    | Description          | Default |
|-----------|----------------------|---------|
| *create*  | Create the record.   | Yes     |
| *destroy* | Destroy the record.  |         |

Parameter Attributes:

The type of record can be one of the following: A, CNAME, ALIAS, MX, SPF, URL, TXT, NS, SRV, NAPTR, PTR, AAA, SSHFP, or HFINO.

| Parameter  | Description                     | Default |
|------------|---------------------------------|---------|
| *domain*   | Domain to manage                |         |
| *name*     | _Name_: Name of the record      |         |
| *type*     | Type of DNS record              |         |
| *content*  | String/Array content of records |         |
| *ttl*      | Time to live.                   | 3600    |
| *priority* | Priorty of update               |         |
| *username* | DNSimple username               |         |
| *password* | DNSimple password               |         |
| *test*     | Unused at this time             | false   |

Examples

    dnsimple_record "create an A record" do
      name     "test"
      content  "16.8.4.2"
      type     "A"
      domain   node[:dnsimple][:domain]
      username node[:dnsimple][:username]
      password node[:dnsimple][:password]
      action   :create
    end

    dnsimple_record "create a CNAME record for a Google Apps site calendar" do
      name     "calendar"
      content  "ghs.google.com"
      type     "CNAME"
      domain   node[:dnsimple][:domain]
      username node[:dnsimple][:username]
      password node[:dnsimple][:password]
      action   :create
    end

    dnsimple_record "create a A record with multiple content values" do
      name     "multiple"
      content  ["1.1.1.1", "2.2.2.2"]
      type     "A"
      domain   node[:dnsimple][:domain]
      username node[:dnsimple][:username]
      password node[:dnsimple][:password]
      action   :create
    end

Usage

Add the the dnsimple recipe to a node's run list, or with include_recipe to install the fog gem, which is used to interact with the DNSimple API. See examples of the LWRP usage above.

Testing

To run the tests across all platforms, you want to grab the latest ChefDK install VirtualBox, Vagrant, and the Chefstyle gem into your ChefDK then run chef exec kitchen test.

License and Author

Copyright:: 2014-2016 Aetrion, LLC

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

1.2.0 / 2016-06-09

This will be the last non-bugfix version to use the fog gem and the v1 API.

Bug Fixes

  • Nokogiri now bundles libxml2 and libxslt making life somewhat easier for us and simplifying the default recipe, which was broken at the time. We've removed the dependency package installs with exception of zlibg1 for debian family platforms.
  • Change chef_gem resource usage to not break in chef 12 or chef 11

Test suite

  • Resolved all foodcritic warnings with the newest foodcritic
  • Resolved the chefspec and compile_time warnings
  • change to chefstyle
  • Clean up and simplify tests with rake
  • fix up travis tests

1.1.0 / 2015-03-06

Breaking Changes

  • Changed fog version number to nil, which causes it to install the latest version. This will cause a conflict with Chef 12.1.0 and is currently a known issue. If you are going to set a version, then it is suggested to use at least 1.20.0, which contains the updated api endpoint.

Enhancements

  • Added support for multiple content values in a record via arrays (#20 by @josacar)

    Bug Fixes

  • Use latest Fog gem release, not the master git branch.

  • Unpinned build-essential to resolve version constraint issues (#22 by @martinb3)

Testing

  • Updated and cleaned up test suite to be RSpec 3.0 compatible (truthy and falsy)
  • Upgraded to Berkshelf 3.0
  • Upgraded to ChefSpec 4.0 which officially makes this cookbook Chef 11.x or higher compatible. Noted in the README.
  • Cleaned up and updated copyrights in the licensing notices

Foodcritic Metric
            

1.2.0 passed this metric