Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

The omnibus_updater cookbook has been deprecated

The omnibus_updater cookbook has been deprecated and is no longer being maintained by its authors. Use of the omnibus_updater cookbook is no longer recommended. You may find that the chef_client_updater cookbook is a suitable alternative.

RSS

omnibus_updater (23) Versions 0.0.3

Chef omnibus package updater and installer

Berkshelf/Librarian
Policyfile
Knife
cookbook 'omnibus_updater', '= 0.0.3'
cookbook 'omnibus_updater', '= 0.0.3', :supermarket
knife cookbook site install omnibus_updater
knife cookbook site download omnibus_updater
README
Dependencies
Quality

OmnibusUpdater

Update your omnibus! This cookbook can install the omnibus Chef package into your system if you are currently running via gem install, and it can keep your omnibus install up to date.

Usage

Add the recipe to your run list and specify what version should be installed on the node:

knife node run_list add recipe[omnibus_updater]

In your role you'll likely want to set the version (it defaults to the 0.10.10 version of Chef):

override_attributes(
  :omnibus_updater => {
    :version => '10.12.0.rc.1'
  }
)

It can also uninstall Chef from the system Ruby installation if you tell it to:

override_attributes(
  :omnibus_updater => {
    :remove_chef_system_gem => true
  }
)

If you are using a Chef version earlier than 10.12.0 you may want to take a look at the chef_gem cookbook to ensure gems are going

where expected.

The default recipe will install the omnibus package based on system information but you can override that by using the install_via attribute which accepts: deb, rpm or script.

Infos

No quality metric results found