Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

chocolatey (22) Versions 1.1.0

Install chocolatey and packages on Windows

Berkshelf/Librarian
Policyfile
Knife
cookbook 'chocolatey', '= 1.1.0'
cookbook 'chocolatey', '= 1.1.0', :supermarket
knife cookbook site install chocolatey
knife cookbook site download chocolatey
README
Dependencies
Changelog
Quality

Cookbook Version Build Status

Description

Install Chocolatey with the default recipe and manage packages with a handy resource/provider.

Requirements

Platform:

  • Windows
  • Chef 11.6 or greater

Cookbooks:

  • windows (~> 1.38)

Notes

As of Chocolatey version 0.9.8.24 the install directory for Chocolatey has changed from C:\Chocolatey to C:\ProgramData\Chocolatey.

More information can be gotten from the Chocolateywiki.

Attributes

All attributes below are pre-pended with node['chocolatey']

Attribute Description Type Default
['upgrade'] Whether to upgrade Chocolatey if it's already installed Boolean true
['install_vars']['chocolateyProxyLocation'] HTTPS proxy for Chocolatey install script String Chef::Config['https_proxy'] or ENV['https_proxy']
['install_vars']['chocolateyProxyUser'] Proxy user for authenticating proxies String nil
['install_vars']['chocolateyProxyPassword'] Proxy user password String nil
['install_vars']['chocolateyVersion'] Version of Chocolatey to install, e.g. '0.9.9.11' String nil (download latest version)
['install_vars']['chocolateyDownloadUrl'] Chocolatey .nupkg file URL. Use this if you host an internal copy of the chocolatey.nupkg String https://chocolatey.org/api/v2/package/chocolatey (download from chocolatey.org)

Recipes

  • chocolatey::default

Resources

chocolatey

Note: On chef client versions 12.7.0 and greater, Use the chocolatey_package resource instead.

Actions

  • install: Install a chocolatey package (default)
  • remove: Uninstall a chocolatey package
  • upgrade: Update a chocolatey package

Resource Properties

  • package: package to manage (default name)
  • source: The source to find the package(s) to install
  • version: The version of the package to use.
  • args: arguments to the installation.
  • options: Hash of additional options to be sent to choco.exe

Examples

include_recipe 'chocolatey'

%w{sysinternals 7zip notepadplusplus GoogleChrome Console2}.each do |pack|
  chocolatey pack
end

%w{bash openssh grep}.each do |pack|
  chocolatey pack do
    source 'cygwin'
  end
end

chocolatey 'git.install' do
    options ({ 'params' => "'/GitOnlyOnPath'" })
end

chocolatey 'wireshark' do
  version '1.12.6'
  action :install
end

chocolatey "some_private_secure_package" do
  source "https://some.proget/feed"
  options ({'u' => 'username', 'p' => 'password'})
end

chocolatey 'DotNet4.5'

chocolatey 'PowerShell'

License and Maintainer

Maintainer:: Guilhem Lettron (guilhem@lettron.fr)

License:: Apache 2.0

Dependent cookbooks

windows >= 1.38

Contingent cookbooks

atom Applicable Versions
chefdk_bootstrap Applicable Versions
chocolatey-installer Applicable Versions
consul Applicable Versions
gauge Applicable Versions
icinga2 Applicable Versions
icinga2_core Applicable Versions
nsclient Applicable Versions
nscp Applicable Versions
nuget Applicable Versions
nugetclient Applicable Versions
opencv Applicable Versions
pantry Applicable Versions
phantomjs Applicable Versions
windev Applicable Versions
yacc Applicable Versions
zabbix Applicable Versions
zabbix-agent Applicable Versions
zabbix_lwrp Applicable Versions

Changelog for Chocolatey cookbook

v1.1.0 (2017-01-09)

  • Update the chocolatey install script to match chocolatey.org.

v1.0.3 (2016-09-12)

  • Loosen windows-cookbook constraint

v1.0.2 (2016-08-29)

  • Ensure chocolateyVersion attribute is used and the correct version of chocolatey is installed.

v1.0.1 (2016-07-15)

  • Always execute chocolatey installer unless guard is satisfied to allow the install to retry on subsequent attempts if it fails.

v1.0.0 (2016-03-07)

  • No longer dependent on chocolatey.org for install script
  • Removed deprecated overwriting of the current_resource and fixed visibility problem with env_path

v0.6.2 (2016-01-07)

  • Fix Chocolatey detection on chef clients older than 12.4.0

v0.6.1 (2015-11-24)

  • Fix LocalJumpError on existing chocolatey package

v0.6.0 (2015-11-17)

  • Path Tracking. Tracking additions to the user and machine %PATH% environment and merging them into the current process.
  • Downcase package name results from choco upgrade.

v0.5.1 (2015-11-10)

  • Prepend library include with :: in provder to fix 12.3.0 and likely other versions older than 12.5.1.
  • Add backward compatibiliy to new metadata.rb attributes source_url and issues_url.

v0.5.0 (2015-11-09)

  • Refactored install script (and .kitchen.yml) to support installing Chocolatey in test-kitchen behind a proxy.
  • Download node['chocolatey']['Uri'] via remote_file resource instead of .net web client
  • Set chocolateyProxyLocation environment variable to Chef::Config['https_proxy'] if one is set before chocolatey install
  • Changed helpers module namespacing from: ChocolateyHelpers to Chocolatey::Helpers
  • Add ChefSpec unit tests
  • Add ServerSpec integration tests
  • Gemfile: bump foodcritic to 5.0 and Berkshelf to 4.0
  • Add ChefSpec matchers

v0.4.1 (2015-10-15)

  • Adds example how to install package with version
  • use the vanilla script resource to bypass 64bit interpreter builder introduced in Chef 12.5

v0.4.0 (2015-06-30)

  • Refactor script to download Chocolatey install script
  • Chocolatey install: add proxy support
  • fix for 64-bit chocolatey installs

v0.3.0 (2015-04-20)

  • Support for chocolatey >= 0.9.9
  • Make package name case insensitive

v0.2.0 (2014-09-24)

  • Allow spaces in the path to the "choco" command.
  • Update tests to use Rakefile
  • Support Chocolatey version 0.9.8.24+
  • Support custom command line options when installing packages

v0.1.0 (2014-02-20)

  • Fix and tests

v0.0.5 (2013-04-30)

  • Initial release

Collaborator Number Metric
            

1.1.0 passed this metric

Contributing File Metric
            

1.1.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of http://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

1.1.0 failed this metric

FC074: LWRP should use DSL to define resource's default action: chocolatey/resources/default.rb:1
Run with Foodcritic Version 10.3.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

1.1.0 passed this metric

No Binaries Metric
            

1.1.0 passed this metric

Publish Metric
            

1.1.0 passed this metric

Supported Platforms Metric
            

1.1.0 passed this metric

Testing File Metric
            

1.1.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of http://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

1.1.0 passed this metric