Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

activemq (23) Versions 2.0.4

Installs activemq and sets it up as service

Berkshelf/Librarian
Policyfile
Knife
cookbook 'activemq', '= 2.0.4'
cookbook 'activemq', '= 2.0.4', :supermarket
knife cookbook site install activemq
knife cookbook site download activemq
README
Dependencies
Changelog
Quality 100%

activemq Cookbook

Build Status Cookbook Version

Installs Apache ActiveMQ and sets up the service using the included init script.

Requirements

Platforms

  • Debian/Ubuntu
  • RHEL/CentOS/Scientific/Amazon/Oracle

Chef

  • Chef 11+

Cookbooks

  • java

Attributes

  • node['activemq']['mirror'] - download URL up to the activemq/apache-activemq directory.
  • node['activemq']['version'] - version to install.
  • node['activemq']['home'] - directory to deploy to (/opt by default)
  • node['activemq']['wrapper']['max_memory'] - maximum amount of memory to use for activemq.
  • node['activemq']['wrapper']['useDedicatedTaskRunner'] - whether to use the dedicated task runner
  • node['activemq']['enable_stomp'] - Flag that decides whether or not to use stomp. Note: This is only used when use_default_config attribute is true.
  • node['activemq']['use_default_config'] - Flag that allows the option to use a basic configuration file
  • node['activemq']['install_java'] - Whether or not to use the Java community cookbook to install Java. Defaults to true.
  • node['activemq']['enabled'] - Whether or not the ActiveMQ service should be started. Defaults to true.

Usage

Simply add recipe[activemq] to a run list.

License & Authors

Author: Cookbook Engineering Team (cookbooks@chef.io)

Copyright: 2008-2015, Chef Software, Inc.

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

    http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Dependent cookbooks

java ~> 1.13

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

activemq Cookbook CHANGELOG

This file is used to list changes made in each version of the activemq cookbook.

v2.0.4 (2015-12-03)

  • Add a new attribute for setting transport protocols: default['activemq']['transport_protocols']

v2.0.3 (2015-11-02)

  • Install tar for minimal rhel installs that might not have it
  • Test in Travis with kitchen-docker so each commit triggers a full integration test
  • Update the development and testing gems in the Gemfile

v2.0.2 (2015-09-24)

  • Add new attributes for controlling the SSL settings
    • default['activemq']['wrapper']['keystore_password']
    • default['activemq']['wrapper']['truststore_password']
    • default['activemq']['wrapper']['keystore_path']
    • default['activemq']['wrapper']['truststore_path']

v2.0.1 (2015-09-11)

  • Update metadata for the move from opscode-cookbooks to chef-cookbooks
  • Resolve rubocop warnings in the Rakefile and Rake tasks
  • Remove incorrect development documentation in the readme
  • Update the author to be the Cookbook Engineering Team
  • Add additional development gems for rake and cloud testing

v2.0.0 (2015-09-07)

  • Default to ActiveMQ version 5.12.0
  • Updated to the latest out of the box ActiveMQ config XML file so that newer installs could be successfully started. This is a 100% breaking change for older ActiveMQ installs.
  • Added new attribute to decide if the service should be started or not: node['activemq']['enabled']. Defaults to true, but can be used with wrapper cookbooks that need to install additional configs before starting ActiveMQ
  • Added new attribute to decide if Java should be installed or not: node['activemq']['install_java']. Defaults to true
  • Fixed wrapper.conf to only template if node['activemq']['use_default_config'] is set
  • Updated Berksfile to 3.0 format
  • Update Kitchen CI config with additional platforms and the attributes necessary for a clean converge
  • Update Travis CI to test on Ruby 2/2.1/2.2 and to use the containe infrastructure and bundler caching for faster tests
  • Removed yum as a dependency in the Berksfile since it's not actually used anywhere
  • Added the new contributing and testing docs
  • Add a maintainers file
  • Updated all development dependencies in the Gemfile
  • Clarified that Chef 11+ is required in the readme
  • Added Travis and Supermarket badges in the readme
  • Added scientific oracle, and amazon to the metdata file
  • Add source_url and issues_url metadata to the metadata file
  • Added minimal Chefspec to test recipe convergence
  • Updated .gitignore and added a chefignore file
  • Fix serverspec tests to run with the the latest serverspec release

v1.3.5

  • Adding global amq distribution service switch

v1.3.4 (Development)

v1.3.3 (2015-04-03)

  • Metadata includes issues_url and source_url

v1.3.2 (2014-04-23)

  • [COOK-4557] activemq cookbook default mirror url is broken

v1.3.0

Bug

  • COOK-3309 - Fix service (re)start command
  • COOK-2846 - Add support for openSUSE
  • COOK-2845 - Support differing versions of wrapper.conf

v1.2.0

New Feature

v1.1.0

  • [COOK-2816] - update version to 5.8.0
  • [COOK-2817] - resolve foodcritic warning

v1.0.2

  • [COOK-800] - activemq cookbook should install 5.5.1 by default
  • [COOK-872] - activemq home directory isn't explicitly created

Foodcritic Metric
            

2.0.4 passed this metric