Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms


backslasher-python (14) Versions 0.1.1

Installs/Configures python and python accessories

cookbook 'backslasher-python', '= 0.1.1'
cookbook 'backslasher-python', '= 0.1.1', :supermarket
knife cookbook site install backslasher-python
knife cookbook site download backslasher-python
Quality 100%


A cookbook for managing python-related resources in a simple way
This is mostly a ripoff of the python cookbook, since it's both deprecated and has its resource names stolen by poise-python cookbook

  • backslasher_python_pip_installer: Makes sure a python envrionment has pip installed
  • backslasher_python_pip: A pip package
  • backslasher_python_virtualenv: A virtual environment

Supported Platforms

Should work on normal Linux boxes. Possibly on Windows.
I'm testing on:

  • Ubuntu 14.04
  • CentOS 6 (6.7)
  • CentOS 7 (7.1)


  • ['backslasher-python']['install_method']: How to install python. Defaults to package. I'm currently not supoorting any other method.



The works - installs Python, pip and virtualenv.
Python is installed according to ['backslasher-python']['install_method']


Installs python using the repo's packages.
Provides both python runtime and Python development headers


Installs pip on the "regular" Python (the one available as python)


Installs the virtualenv pip package on the "regular" Python. Also makes sure pip is installed.



Installs pip on a specific python executable


  • python_path: Python binary to install pip on.
    Defaults to python, which should find the "system" python

Note: This action might overwrite the "primary"pip binary. There is no easy way to avoid this since there is no way to instruct setuptools not to create "entry points". I'll happily accept a PR for fixing this.


Installs/removed/upgrades a pip package


  • install: Install the pip package
  • upgrade: Upgrade the pip package if it is uninstalled / has version mismatch. Will upgrade to latest by default.
  • remove: Remove the pip package if installed


  • python_path: Python binary to install on.
    Not relevant if using virtualenv property.
    Defaults to python, which should find the "system" python.
  • package_name: Pip package to install. Defaults to the resource's name
  • `package_url: Optional. Used to specify a URL to install the package from (e.g. pip install git+git://
  • version: Optional. Specifies a pip version to install
  • virtualenv: Optional. Specifies a virtualenv path to install/remove the pip package in
  • timeout: Time allotted for pip commands. Defaults to 900 seconds (15 min)
  • `user: User to run the commands under
  • group: Group to run the commands under
  • environment: Hash of environment variables to pass to the pip commands
  • options: An array of arguments to pass to the pip commands


Manages a python virtualenv


  • create: Creates the virtualenv
  • delete: Deletes the virtualenv


  • path: Location inside the filesystem of the virtualenv. Defaults to the resource's name
  • interpreter: Optional. Python binary used for venv. Defaults to the system python
  • owner: Optional. Owning user of the virtualenv
  • group: Optional. Owning group of the virtualenv
  • options: Optional. A string of arguments to pass the virtualenv creator

License and Authors


Dependent cookbooks

yum-epel ~> 0.6
compat_resource = 12.5.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.


  • [backslasher] Foodcritic issues


  • [backslasher] Initial release of backslasher-python

Foodcritic Metric

0.1.1 passed this metric