Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

rom bob's Cookbooks

Owns
Collaborates
Follows
  • mesos 3.6.0

    75% Updated December 6, 2016

    Installs/Configures Apache Mesos

    cookbook 'mesos', '~> 3.6.0'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
    • oracle >= 0.0.0
  • mongodb 0.16.2

    38% Updated March 24, 2017
    Deprecated in favor of sc-mongodb

    Installs and configures mongodb

    cookbook 'mongodb', '~> 0.16.2'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • amazon >= 0.0.0
  • monitor 0.0.4

    38% Updated October 2, 2013

    A cookbook for monitoring services, using Sensu, a monitoring framework.

    cookbook 'monitor', '~> 0.0.4'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
  • munin-statsd 0.1.0

    25% Updated May 5, 2013

    Installs and Configures the munin-statsd.pl bridge

    cookbook 'munin-statsd', '~> 0.1.0'
    Supported Platforms
  • mysql 8.5.1

    100% Updated May 29, 2018

    Provides mysql_service, mysql_config, and mysql_client resources

    cookbook 'mysql', '~> 8.5.1'
    Supported Platforms
    • fedora >= 0.0.0
    • scientific >= 6.0
    • centos >= 6.0
    • redhat >= 6.0
    • amazon >= 0.0.0
    • ubuntu >= 12.04
    • oracle >= 6.0
    • debian >= 7.0
    • opensuseleap >= 0.0.0
    • suse >= 12.0
    • opensuse >= 13.0
  • nginx 10.0.2

    100% Updated October 16, 2019

    Installs and configures nginx

    cookbook 'nginx', '~> 10.0.2'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • suse >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
    • opensuse >= 0.0.0
    • oracle >= 0.0.0
    • opensuseleap >= 0.0.0
  • nginx_vhost 0.1.0

    38% Updated January 4, 2013

    Installs/Configures nginx_vhost

    cookbook 'nginx_vhost', '~> 0.1.0'
    Supported Platforms
    • rhel >= 0.0.0
    • debian >= 0.0.0
  • onddo_proftpd 2.1.0

    38% Updated September 8, 2015

    Installs and Configures ProFTPD ftp server.

    cookbook 'onddo_proftpd', '~> 2.1.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • amazon >= 0.0.0
  • openvpn 4.0.0

    100% Updated January 21, 2019

    Installs and configures openvpn and includes rake tasks for managing certs.

    cookbook 'openvpn', '~> 4.0.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • arch >= 0.0.0
  • percona 0.16.5

    63% Updated March 12, 2019

    Installs Percona MySQL client and server

    cookbook 'percona', '~> 0.16.5'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
  • php 7.0.0

    100% Updated August 7, 2019

    Installs and maintains php and php modules

    cookbook 'php', '~> 7.0.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • suse >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
    • opensuse >= 0.0.0
    • oracle >= 0.0.0
    • opensuseleap >= 0.0.0
  • php5_ppa 0.1.2

    38% Updated March 1, 2014

    Installs/Configures php5 from ppa

    cookbook 'php5_ppa', '~> 0.1.2'
    Supported Platforms
    • ubuntu >= 0.0.0
  • polyglot 1.0.0

    25% Updated May 8, 2013

    Easy defaults for ruby, python, clojure, java, and android

    cookbook 'polyglot', '~> 1.0.0'
    Supported Platforms
  • postfix 5.3.1

    100% Updated July 24, 2018

    Installs and configures postfix for client or outbound relayhost, or to do SASL auth

    cookbook 'postfix', '~> 5.3.1'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • freebsd >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • scientific >= 0.0.0
    • amazon >= 0.0.0
    • oracle >= 0.0.0
    • smartos >= 0.0.0
  • pptpd 1.0.1

    38% Updated July 9, 2011

    Installs pptpd

    cookbook 'pptpd', '~> 1.0.1'
    Supported Platforms
    • ubuntu >= 0.0.0
  • proxy 1.0.0

    25% Updated May 3, 2013

    Sets up instances for proxying traffic

    cookbook 'proxy', '~> 1.0.0'
    Supported Platforms
  • raspberry-pi 0.1.1

    25% Updated May 2, 2015

    Handles initial configuration of a Raspberry Pi

    cookbook 'raspberry-pi', '~> 0.1.1'
    Supported Platforms
  • sensu 5.4.0

    100% Updated September 14, 2018

    Installs/Configures Sensu

    cookbook 'sensu', '~> 5.4.0'
    Supported Platforms
    • centos >= 0.0.0
    • fedora >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • suse >= 0.0.0
    • scientific >= 0.0.0
    • windows >= 0.0.0
    • amazon >= 0.0.0
    • oracle >= 0.0.0
    • aix >= 0.0.0
    Badges
  • sysctl 1.1.0

    88% Updated November 7, 2019
    Deprecated

    Configures sysctl parameters

    cookbook 'sysctl', '~> 1.1.0'
    Supported Platforms
    • redhat >= 0.0.0
    • centos >= 6.0
    • amazon >= 0.0.0
    • suse >= 11.0
    • pld >= 0.0.0
    • scientific >= 6.4
    • ubuntu >= 14.04
    • debian >= 8.0
    • opensuseleap >= 0.0.0
  • vagrant 2.0.0

    100% Updated October 16, 2019

    Installs Vagrant and provides a vagrant_plugin resource for installing Vagrant plugins.

    cookbook 'vagrant', '~> 2.0.0'
    Supported Platforms
    • centos >= 0.0.0
    • debian >= 0.0.0
    • ubuntu >= 0.0.0
    • redhat >= 0.0.0
    • mac_os_x >= 0.0.0
    • windows >= 0.0.0