Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

yum-updatesd (2) Versions 0.1.1

Installs/Configures yum-updatesd

Berkshelf/Librarian
Policyfile
Knife
cookbook 'yum-updatesd', '~> 0.1.1'
cookbook 'yum-updatesd', '~> 0.1.1', :supermarket
knife cookbook site install yum-updatesd
knife cookbook site download yum-updatesd
README
Dependencies
Changelog
Quality

Description

yum-updatesd provides notification of updates which are available to be applied to your system. This notification can be done either via syslog, email or over dbus.

Requirements

  • Chef 11 or higher
  • Ruby 1.9 (preferably from the Chef full-stack installer)
  • RHEL5, RHEL6, or other platforms within the family

Attributes

The following attributes are set by default

#Main
# Number of seconds to wait between checks for available updates. 
default['yum-updatesd']['run_interval'] = 3600
# Minimum number of seconds between update information refreshes to avoid hitting the server too often. 
default['yum-updatesd']['updaterefresh'] = 600
# List of ways to emit update notification. Valid values are 'email', 'dbus' and 'syslog'. 
default['yum-updatesd']['emit_via'] = syslog
# Boolean option to decide whether or not updates should be automatically applied. Defaults to False. 
default['yum-updatesd']['do_update'] = False
# Boolean option to decide whether or not updates should be automatically downloaded. Defaults to False. 
default['yum-updatesd']['do_download'] = False
# Boolean option to automatically download dependencies of packages which need updating as well. Defaults to False. 
default['yum-updatesd']['do_download_deps'] = False
# Boolen option to listen via dbus to give out update information/check for new updates
default['dbus_listener']['do_download_deps'] = False

#Mail Options
# List of email addresses to send update notification to. Defaults to 'root@localhost'. 
default['yum-updatesd']['email_to'] = 'root@localhost' 
# Email address for update notifications to be from. Defaults to 'yum-updatesd@localhost'. 
default['yum-updatesd']['email_from'] = 'yum-updatesd@localhost'
# SMTP server to use when sending mail, host or a host:port string. Defaults to 'localhost:25'. 
default['yum-updatesd']['smtp_server'] = 'localhost:25'

#Syslog Options
# What syslog facility should be used. Defaults to 'DAEMON'. 
default['yum-updatesd']['syslog_facility'] = 'DAEMON'
# Level of syslog messages. Defaults to 'WARN'. 
default['yum-updatesd']['syslog_level'] =  'WARN'

Usage

yum-updatesd

Just include yum-updatesd in your node's run_list:

License & Authors

Copyright:: 2015 David Hofmann

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

    http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Dependent cookbooks

This cookbook has no specified dependencies.

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

yum-updatesd CHANGELOG

This file is used to list changes made in each version of the yum-updatesd cookbook.

0.1.1

  • David Hofmann - Fixed Template Error

0.1.0

  • David Hofmann - Initial release of yum-updatesd

Collaborator Number Metric
            

0.1.1 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.1.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

0.1.1 failed this metric

FC064: Ensure issues_url is set in metadata: yum-updatesd/metadata.rb:1
FC065: Ensure source_url is set in metadata: yum-updatesd/metadata.rb:1
FC066: Ensure chef_version is set in metadata: yum-updatesd/metadata.rb:1
Run with Foodcritic Version 11.1.0 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.1.1 failed this metric

yum-updatesd does not have a valid open source license.
Acceptable licenses include Apache-2.0, apachev2, Apache 2.0, MIT, mit, GPL-2.0, gplv2, GNU Public License 2.0, GPL-3.0, gplv3, GNU Public License 3.0.

No Binaries Metric
            

0.1.1 passed this metric

Publish Metric
            

0.1.1 passed this metric

Supported Platforms Metric
            

0.1.1 passed this metric

Testing File Metric
            

0.1.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.1.1 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number