Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

sublime-text (6) Versions 0.1.5

Installs/Configures Sublime Text

Berkshelf/Librarian
Policyfile
Knife
cookbook 'sublime-text', '~> 0.1.5'
cookbook 'sublime-text', '~> 0.1.5', :supermarket
knife cookbook site install sublime-text
knife cookbook site download sublime-text
README
Dependencies
Changelog
Quality

sublime-text Cookbook

Cookbook Version

Cookbook for installing Sublime Text

Supported Platforms

  • Ubuntu 14.04
  • OS X
  • RHEL families (RHEL, CentOS, Scientific)

Attributes

<table> <tr> <th>Key</th> <th>Type</th> <th>Description</th> <th>Default</th> </tr> <tr> <td>node['sublime-text']['version']['generation']</td> <td>integer</td> <td>The generation of Sublime Text to install. Currently supports 2 and 3</td> <td>2</td> </tr> <tr> <td>node['sublime-text']['version']['id']</td> <td>string</td> <td>The version id of Sublime Text to install. For Sublime Text 2, this will be a version number, and for Sublime Text 3 this will be a build number. An appropriate default will be selected for each generation.</td> <td>'2.0.2' (2) or 'Build 3065' (3)</td> </tr> <tr> <td>node['sublime-text']['platform']['release']</td> <td>string</td> <td>The release of ubuntu being installed to (if applicable)</td> <td>'trusty'</td> </tr> <tr> <td>node['sublime-text']['platform']['architecture']</td> <td>string</td> <td>The hardware architecture</td> <td>'amd64'</td> </tr> <tr> <td>node['sublime-text']['tarball']['uri']</td> <td>string</td> <td>The location for Sublime Text tarballs used for linux installation. Override node['sublime-text']['platform']['architecture'] with 'x32', otherwise will default to 64 bit installation</td> <td>'http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%202.0.2.tar.bz2'</td> </tr> <tr> <td>node['sublime-text']['linux']['install_dir']</td> <td>string</td> <td>Installation directory used in linux</td> <td>'/opt'</td> </tr> </table>

Usage

sublime-text::default

Include sublime-text in your node's run_list:

{
  "run_list": [
    "recipe[sublime-text]"
  ]
}

Contributing

  1. Fork the repository on Github
  2. Create a named feature branch (i.e. add-new-recipe)
  3. Write your change
  4. Write tests for your change (if applicable)
  5. Run the tests, ensuring they all pass
  6. Submit a Pull Request

License and Authors

License: MIT

Dependent cookbooks

ark >= 0.9.0
apt >= 2.4

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

0.1.5

  • Fix spelling derp

0.1.4

  • Add icon for linux desktop, default to x64 instead of 32

0.1.3

  • Added support for rhel family distros (RHEL, CentOS, etc), updated maintainer

0.1.2

  • Added OS X functionality (contributed by 0x783czar)
  • Relaxed apt dependency to allow >= 2.4 instead of ~> 2.4 (contributed by obazoud)

0.1.1

Initial release of sublime-text-cookbook

Collaborator Number Metric
            

0.1.5 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.1.5 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

0.1.5 failed this metric

FC064: Ensure issues_url is set in metadata: sublime-text/metadata.rb:1
FC065: Ensure source_url is set in metadata: sublime-text/metadata.rb:1
FC066: Ensure chef_version is set in metadata: sublime-text/metadata.rb:1
FC070: Ensure supports metadata defines valid platforms: sublime-text/metadata.rb:1
Run with Foodcritic Version 11.1.0 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.1.5 passed this metric

No Binaries Metric
            

0.1.5 passed this metric

Publish Metric
            

0.1.5 passed this metric

Supported Platforms Metric
            

0.1.5 passed this metric

Testing File Metric
            

0.1.5 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.1.5 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number