Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

polyglot (1) Versions 1.0.0

Easy defaults for ruby, python, clojure, java, and android

Berkshelf/Librarian
Policyfile
Knife
cookbook 'polyglot', '~> 1.0.0'
cookbook 'polyglot', '~> 1.0.0', :supermarket
knife cookbook site install polyglot
knife cookbook site download polyglot
README
Dependencies
Quality 33%

Polyglot

Cookbook for easily setting up a sane Ruby, Java, Clojure, Python, and Android environment. Made to complement Builder, but a good starting point for any team working with a variety of languages, especially on the JVM.

Usage

This cookbook makes some assumptions about your deployment environment, but ships with attributes to make switching things in or out as easy as possible.

The standard environment you get via polyglot::default is: * Oracle JDK6 * Maven 3.0.5 * Ruby 2.0.0-rc1 * JRuby 1.7.2 * Leiningen 2 * Python 2.7.1 * Android SDK 21.1 (disabled by default)

In the near future, we'll extend this cookbook for some other languages. Since this cookbook is a wrapper for a variety of language-specific cookbooks, it's easy to swap out attribute values for another that you'd prefer. They are as follows:

  • Java: node[:java][:java_flavor]
  • Maven: node[:maven][:version]
  • (J)Ruby: node[:rbenv][:rubies]
  • Leiningen: node[:polyglot][:clojure][:lein_url]
  • Python: node[:python][:version]
  • Android: node[:polyglot][:android][:sdk_url]

Author

Simple Finance ops@simple.com

License

Apache License, Version 2.0

Dependent cookbooks

ruby_build >= 0.0.0
ruby >= 0.0.0
rbenv >= 0.0.0
python >= 0.0.0
maven >= 0.0.0
java >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

1.0.0 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

1.0.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

1.0.0 failed this metric

FC064: Ensure issues_url is set in metadata: polyglot/metadata.rb:1
FC065: Ensure source_url is set in metadata: polyglot/metadata.rb:1
FC066: Ensure chef_version is set in metadata: polyglot/metadata.rb:1
FC067: Ensure at least one platform supported in metadata: polyglot/metadata.rb:1
FC069: Ensure standardized license defined in metadata: polyglot/metadata.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

1.0.0 passed this metric

No Binaries Metric
            

1.0.0 passed this metric

Publish Metric
            

1.0.0 passed this metric

Supported Platforms Metric
            

1.0.0 failed this metric

polyglot should declare what platform(s) it supports.

Testing File Metric
            

1.0.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

1.0.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number