Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

google-authenticator (3) Versions 0.1.8

Installs/Configures google-authenticator

Berkshelf/Librarian
Policyfile
Knife
cookbook 'google-authenticator', '~> 0.1.8'
cookbook 'google-authenticator', '~> 0.1.8', :supermarket
knife cookbook site install google-authenticator
knife cookbook site download google-authenticator
README
Dependencies
Quality 33%

google-authenticator Cookbook

Installs google-authenticator and updated pam to support use it. The following recipes are included:

  • google-authenticator::sshd
    • configures sshd to support google-authenticator

Requirements

This has been tested and locked on Fedora 19. Future support will be added for other distributions.

For testing and code contribution, use FoodCritic and ChefSpec.

Attributes

  • ['google-authenticator']['package_name'] - name of google package authentication package. Defaults to google-authenticator
  • ['google-authenticator']['sshd_pamd'] - location of sshd pam module. Defaults to /etc/pam.d/sshd

Installation

You can download directly using the knife cookbook tool. If you want to get the latest version:

  1. Create a directory called google-authenticator in your cookbook directory
  2. cd to that directory
  3. clone from the repo with: git git@github.com:rilindo/cookbook-google-authenticator.git .

Usage

To install just the package package:

{
  "name":"my_node",
  "run_list": [
    "recipe[google-authenticator]",
  ]
}

To update sshd to support google-authenticator, in your node's run_list, include the sshd recipe along with opscode's openssh:

{
  "name":"my_node",
  "run_list": [
    "recipe[google-authenticator]",
    "recipe[google-authenticator::sshd]":,
    "recipe[openssh]"
  ]
}

Then override the server attribute for openssh with:

{
    "server":{
        "ChallengeResponseAuthentication":"yes"
    }
}

(in a future update, this may be added as an explicit attribute change)

You may also override ['google-authenticator']['sshd_pamd'] attribute if the location is different.

Note that this cookbook makes a changes on the pam file through the use of Chef::Util::FileEdit:insert_line_if_no_match(). If you are running a version of Chef client earlier than 10.16.x, this cookbook may not work.

More information on setting up Google Authenticator can be found at this URL:

http://www.mnxsolutions.com/security/two-factor-ssh-with-google-authenticator.html

Contributing

To contribute:

  1. Fork the repository on Github
  2. Create a named feature branch (like add_component_x)
  3. Write you change
  4. Write tests for your change (if applicable)
  5. Run the tests, ensuring they all pass
  6. Submit a Pull Request using Github

License and Authors

Authors: Rilindo Foster rilindo.foster@monzell.com

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Dependent cookbooks

yum >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

0.1.8 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.1.8 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

0.1.8 failed this metric

FC064: Ensure issues_url is set in metadata: google-authenticator/metadata.rb:1
FC065: Ensure source_url is set in metadata: google-authenticator/metadata.rb:1
FC066: Ensure chef_version is set in metadata: google-authenticator/metadata.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.1.8 failed this metric

google-authenticator does not have a valid open source license.
Acceptable licenses include Apache-2.0, apachev2, Apache 2.0, MIT, mit, GPL-2.0, gplv2, GNU Public License 2.0, GPL-3.0, gplv3, GNU Public License 3.0.

No Binaries Metric
            

0.1.8 passed this metric

Publish Metric
            

0.1.8 passed this metric

Supported Platforms Metric
            

0.1.8 passed this metric

Testing File Metric
            

0.1.8 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.1.8 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number