Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

elixir (24) Versions 2.0.0

Manages an Elixir installation

Berkshelf
Policyfile
Knife
cookbook 'elixir', '~> 2.0.0'
cookbook 'elixir', '~> 2.0.0', :supermarket
knife supermarket install elixir
knife supermarket download elixir
README
Dependencies
Changelog
Quality 100%

elixir Cookbook

Cookbook Version CI State OpenCollective OpenCollective License

A cookbook to manage an installation of Elixir.

Maintainers

This cookbook is maintained by the Sous Chefs. The Sous Chefs are a community of Chef cookbook maintainers working together to maintain important cookbooks. If you’d like to know more please visit sous-chefs.org or come chat with us on the Chef Community Slack in #sous-chefs.

Requirements

Platforms

  • Debian/Ubuntu
  • RHEL/CentOS/Scientific/Amazon/Oracle

Chef

  • Chef 14+

Cookbooks

  • git
  • github
  • erlang
  • libarchive

Attributes

Key Type Description Default
node[:elixir][:install_path] String Path that Elixir will reside in "/usr/local/lib/elixir"
node[:elixir][:install_method] String Method of installation: "package" or "source" "package"
node[:elixir][:source][:repo] String Git source repository location "https://github.com/elixir-lang/elixir.git"
node[:elixir][:version] String Version of Elixir to compile "v1.4.2"

Usage

Include elixir in your node's run_list

{
  "run_list": [
    "recipe[elixir::default]"
  ]
}

elixir::default

This will install Elixir and Erlang on the node. By default, Elixir and Erlang will be installed from packages. If you want to install from source you can set the node[:elixir][:install_method] attribute.

Contributors

This project exists thanks to all the people who contribute.

Backers

Thank you to all our backers!

https://opencollective.com/sous-chefs#backers

Sponsors

Support this project by becoming a sponsor. Your logo will show up here with a link to your website.

https://opencollective.com/sous-chefs/sponsor/0/website https://opencollective.com/sous-chefs/sponsor/1/website https://opencollective.com/sous-chefs/sponsor/2/website https://opencollective.com/sous-chefs/sponsor/3/website https://opencollective.com/sous-chefs/sponsor/4/website https://opencollective.com/sous-chefs/sponsor/5/website https://opencollective.com/sous-chefs/sponsor/6/website https://opencollective.com/sous-chefs/sponsor/7/website https://opencollective.com/sous-chefs/sponsor/8/website https://opencollective.com/sous-chefs/sponsor/9/website

elixir Cookbook CHANGELOG

This file is used to list changes made in each version of the elixir cookbook.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

2.0.0 (2020-10-15)

Changed

  • Sous Chefs Adoption
  • Update Changelog to Sous Chefs
  • Update to use Sous Chefs GH workflow
  • Update to Elixir 1.11.0
  • Update README to sous-chefs
  • Update metadata.rb to Sous Chefs
  • Update test-kitchen to Sous Chefs
  • Require newer erlang cookbook and Chef >= 14

Fixed

  • Yamllint fixes
  • Fix idempotency issues

Added

  • Include mdlrc file
  • Add CentOS 8 support
  • Add Ubuntu 18.04 and 20.04 support
  • Add basic InSpec tests

Removed

  • Remove Amazon Linux 1 testing
  • Remove un-necessary directory creation
  • Remove CentOS 6 testing
  • Remove OpenSUSE testing

1.1.0 (2019-10-07)

  • Require the latest libarchive cookbook on Chef 12.6+ - @tas50

1.0.1 (2017-04-19)

  • Remove usage of the validate cookbook that is not chef 13 compatible

1.0.0 (2017-03-15)

  • This cookbook has been transferred to Chef to be maintained by the Cookbook Engineering team
  • Require Chef 12.1 or later
  • Depend on fairly recent releases of git, erlang, and libarchive
  • Resolve all cookstyle and foodcritic warnings
  • Remove the apt::default from the elixir default recipe and instead leave apt updating to the users
  • Install the current stable release of elixir instead of an old release that's not published anymore
  • Update ignore files
  • Add github templates
  • Add local delivery testing config
  • Add maintainers files
  • Add contributing and testing documentation
  • Add full Apache 2.0 license file
  • Remove deps that are in ChefDK from the Gemfile
  • Update platforms in the Test Kitchen config
  • Add a changelog
  • Update the maintainer to be Chef
  • Add source_url, issues_url and chef_version metadata
  • Remove attributes from the metadata file
  • Don’t use node.set for attributes as this is deprecated in Chef 13
  • Add supported operating systems to the metadata
  • Add Travis CI config and kitchen-dokken for integration testing in Travis
  • Remove HTML from the readme so that it renders on Supermarket
  • Update readme attribute document to match actual attributes
  • Add requirements section and license to the readme
  • Update copyright headers

Collaborator Number Metric
            

2.0.0 passed this metric

Contributing File Metric
            

2.0.0 passed this metric

Foodcritic Metric
            

2.0.0 passed this metric

No Binaries Metric
            

2.0.0 passed this metric

Publish Metric
            

2.0.0 passed this metric

Supported Platforms Metric
            

2.0.0 passed this metric

Testing File Metric
            

2.0.0 passed this metric

Version Tag Metric
            

2.0.0 passed this metric