Adoptable Cookbooks List

Looking for a cookbook to adopt? You can now see a list of cookbooks available for adoption!
List of Adoptable Cookbooks

Supermarket Belongs to the Community

Supermarket belongs to the community. While Chef has the responsibility to keep it running and be stewards of its functionality, what it does and how it works is driven by the community. The chef/supermarket repository will continue to be where development of the Supermarket application takes place. Come be part of shaping the direction of Supermarket by opening issues and pull requests or by joining us on the Chef Mailing List.

Select Badges

Select Supported Platforms

RSS

cvs_wrapper (1) Versions 0.1.0

Installs/Configures cvs_wrapper

Berkshelf/Librarian
Policyfile
Knife
cookbook 'cvs_wrapper', '~> 0.1.0'
cookbook 'cvs_wrapper', '~> 0.1.0', :supermarket
knife cookbook site install cvs_wrapper
knife cookbook site download cvs_wrapper
README
Dependencies
Quality 33%

cvs_wrapper

Build Status

Requirements

Usage

This cookbook allows different setups. In static mode (node[:cvs_wrapper][:style] = "static") it will determine the connectivity to the different CVS repositories and configure the SSH tunnels accordingly.

In automatic mode (node[:cvs_wrapper][:style] = "auto") it will perform the connectivity check at runtime. This requires sudo access for the user so that it can modify the /etc/hosts file during runtime.

node[:cvs_wrapper][:sudo] controls that (the default is true). Otherwise, the modification of /etc/hosts is up to the user.

Ideally the cookbook should allow for other solutions, but that is covering my use cases.

What this cookbook does is:

  1. Install CVS
  2. Provide a wrapper to CVS for different directories

Attributes

Recipes

Development

During the development of this cookbook, the main tool used is chefdk, which code is available here.

There are some additional gems that are documented in the project Gemfile. This also allows development in older environments (in general I take my code with me in a USB stick) like MacOSX 10.7, where chefdk is not supported, but the gem version of the tools can be used.

To allow seemless integration of gems, I am using the following approach:

  • use direnv and a .envrc file to ensure the chefdk ruby environment is used when switching to the project folder.
   use_chefdk() {
     eval "$(chef shell-init zsh)"
   }
   use chefdk

Just use your preferred shell instead of zsh. - use the first folder from gem env gempath (which should be a user folder) as destination for the bundle install - bundle install --path $(gem env gempath | cut -f1 -d\: | sed -e 's/\/ruby\/2.1.0//g') - as a note, the vendor/bundle could also be used, but my goal is integrating with the chefdk installation (via bundler).

This adds some gem duplication right now, but I hope everything is ok (work in progress).

Author

Author:: Tnarik Innael (tnarik@lecafeautomatique.co.uk)

Dependent cookbooks

pkgutil >= 0.0.0

Contingent cookbooks

There are no cookbooks that are contingent upon this one.

Collaborator Number Metric
            

0.1.0 failed this metric

Failure: Cookbook has 0 collaborators. A cookbook must have at least 2 collaborators to pass this metric.

Contributing File Metric
            

0.1.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a CONTRIBUTING.md file

Foodcritic Metric
            

0.1.0 failed this metric

FC059: LWRP provider does not declare use_inline_resources: cvs_wrapper/providers/default.rb:1
FC064: Ensure issues_url is set in metadata: cvs_wrapper/metadata.rb:1
FC065: Ensure source_url is set in metadata: cvs_wrapper/metadata.rb:1
FC066: Ensure chef_version is set in metadata: cvs_wrapper/metadata.rb:1
FC069: Ensure standardized license defined in metadata: cvs_wrapper/metadata.rb:1
Run with Foodcritic Version 12.2.1 with tags metadata,correctness ~FC031 ~FC045 and failure tags any

License Metric
            

0.1.0 failed this metric

cvs_wrapper does not have a valid open source license.
Acceptable licenses include Apache-2.0, apachev2, Apache 2.0, MIT, mit, GPL-2.0, gplv2, GNU Public License 2.0, GPL-3.0, gplv3, GNU Public License 3.0.

No Binaries Metric
            

0.1.0 passed this metric

Publish Metric
            

0.1.0 passed this metric

Supported Platforms Metric
            

0.1.0 passed this metric

Testing File Metric
            

0.1.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must contain a TESTING.md file

Version Tag Metric
            

0.1.0 failed this metric

Failure: To pass this metric, your cookbook metadata must include a source url, the source url must be in the form of https://github.com/user/repo, and your repo must include a tag that matches this cookbook version number